summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a7fa7ba2fd..91cc6f6e5e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -351,18 +351,18 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernel. That is, the most recently released major
;; version.
-(define-public linux-libre-5.8-version "5.8.16")
-(define deblob-scripts-5.8
+(define-public linux-libre-5.9-version "5.9.1")
+(define deblob-scripts-5.9
(linux-libre-deblob-scripts
- linux-libre-5.8-version
- (base32 "07z7sglyrfh0706icqqf3shadf638pvyid9386r661ds5lbsa2mw")
- (base32 "0z28yj4f7hhc253hssslm6xl9sg92agbiw50jxb9y72d8zp6sksq")))
-(define-public linux-libre-5.8-pristine-source
- (let ((version linux-libre-5.8-version)
- (hash (base32 "1icxa0pgqhji924ryz37mpjjf4zlkrm8bidanjyn2mzbar7migzx")))
+ linux-libre-5.9-version
+ (base32 "1l0iw2lp6alk0a8nvdafklyks83iiyw4b2r5xif84z47qfbydsis")
+ (base32 "13bvwdca57bij1692yf3g7vlmna55lg4gsgp7279scwjbrrg049a")))
+(define-public linux-libre-5.9-pristine-source
+ (let ((version linux-libre-5.9-version)
+ (hash (base32 "0dn0xz81pphca5dkg6zh8c78p05f63rrr5ihqqsmhc4n73li2jms")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
- deblob-scripts-5.8)))
+ deblob-scripts-5.9)))
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
@@ -460,8 +460,8 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
-(define-public linux-libre-5.8-source
- (source-with-patches linux-libre-5.8-pristine-source
+(define-public linux-libre-5.9-source
+ (source-with-patches linux-libre-5.9-pristine-source
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
@@ -564,9 +564,9 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
-(define-public linux-libre-headers-5.8
- (make-linux-libre-headers* linux-libre-5.8-version
- linux-libre-5.8-source))
+(define-public linux-libre-headers-5.9
+ (make-linux-libre-headers* linux-libre-5.9-version
+ linux-libre-5.9-source))
(define-public linux-libre-headers-5.4
(make-linux-libre-headers* linux-libre-5.4-version
@@ -855,16 +855,16 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
-(define-public linux-libre-5.8
- (make-linux-libre* linux-libre-5.8-version
- linux-libre-5.8-source
+(define-public linux-libre-5.9
+ (make-linux-libre* linux-libre-5.9-version
+ linux-libre-5.9-source
'("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-version linux-libre-5.8-version)
-(define-public linux-libre-pristine-source linux-libre-5.8-pristine-source)
-(define-public linux-libre-source linux-libre-5.8-source)
-(define-public linux-libre linux-libre-5.8)
+(define-public linux-libre-version linux-libre-5.9-version)
+(define-public linux-libre-pristine-source linux-libre-5.9-pristine-source)
+(define-public linux-libre-source linux-libre-5.9-source)
+(define-public linux-libre linux-libre-5.9)
(define-public linux-libre-5.4
(make-linux-libre* linux-libre-5.4-version
@@ -1011,8 +1011,8 @@ It has been modified to remove all non-free binary blobs.")
(define-public linux-libre-with-bpf
(let ((base-linux-libre
(make-linux-libre*
- linux-libre-5.8-version
- linux-libre-5.8-source
+ linux-libre-5.9-version
+ linux-libre-5.9-source
'("x86_64-linux" "i686-linux" "armhf-linux"
"aarch64-linux" "riscv64-linux")
#:extra-version "bpf"