summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fb7c6f2f09..bcdadfbe80 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2786,7 +2786,7 @@ that the Ethernet protocol is much simpler than the IP protocol.")
(define-public iproute
(package
(name "iproute2")
- (version "5.13.0")
+ (version "5.15.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2794,7 +2794,7 @@ that the Ethernet protocol is much simpler than the IP protocol.")
version ".tar.xz"))
(sha256
(base32
- "0dhvdybfm33q9lz73sfnc24pxy2r42xywzb1gdgydjfafhvyb8kj"))))
+ "1zwin8sjnnwf2a9rjwzb3q8lkhcpy06s29sh05f5gxd7z6jy9qrq"))))
(build-system gnu-build-system)
(arguments
`( ;; There is a test suite, but it wants network namespaces and sudo.
@@ -6524,7 +6524,7 @@ the default @code{nsswitch} and the experimental @code{umich_ldap}.")
(define-public mcelog
(package
(name "mcelog")
- (version "176")
+ (version "179")
(source
(origin
(method git-fetch)
@@ -6533,14 +6533,13 @@ the default @code{nsswitch} and the experimental @code{umich_ldap}.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mlwn6ck9qiwqa2vg5wg1gvfva3jv7ygjr7p7bam0qszajs5pirk"))
+ (base32 "0fz9j0p8jyp4m09wshl8cdhdvrdidf29bjp9hgwvv6xvg8lma06g"))
(modules '((guix build utils)))
(snippet
`(begin
;; The checkout lacks a .git directory, breaking ‘git describe’.
(substitute* "Makefile"
- (("\"unknown\"") (string-append "\"v" ,version "\"")))
- #t))))
+ (("\"unknown\"") (string-append "\"v" ,version "\"")))))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -7296,14 +7295,14 @@ available in the kernel Linux.")
(define-public cpuid
(package
(name "cpuid")
- (version "20201006")
+ (version "20211031")
(source (origin
(method url-fetch)
(uri (string-append "http://www.etallen.com/cpuid/cpuid-"
version ".src.tar.gz"))
(sha256
(base32
- "19jnkh57f979b78ak5mpxmdvnkgc33r55cw9shgd2hc380b3zi8k"))))
+ "13sxb2ar4gypiv0l87lr7hf3qjccwgsg1r92adv9jvrfxcv36pbn"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -7318,12 +7317,11 @@ available in the kernel Linux.")
;; Make the compressed manpages writable so that the
;; reset-gzip-timestamps phase does not error out.
(substitute* "Makefile"
- (("-m 444") "-m 644"))
- #t)))))
+ (("-m 444") "-m 644")))))))
(inputs `(("perl" ,perl)))
(supported-systems '("i686-linux" "x86_64-linux"))
(home-page "http://www.etallen.com/cpuid.html")
- (synopsis "Linux tool to dump x86 CPUID information about the CPU(s)")
+ (synopsis "Dump x86 CPUID processor information")
(description "cpuid dumps detailed information about the CPU(s) gathered
from the CPUID instruction, and also determines the exact model of CPU(s). It
supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, UMC,
@@ -7361,7 +7359,7 @@ the MTP device as a file system.")
(define-public procenv
(package
(name "procenv")
- (version "0.58")
+ (version "0.60")
(source
(origin
(method git-fetch)
@@ -7370,7 +7368,7 @@ the MTP device as a file system.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "137n630qzml4yraqzp2fij8nzn8341nf8d58yzfhk8ddlzi60sfm"))))
+ (base32 "00d7q0h4qjc8lg435lq77lp2fx6ikm5piq90m81mr1dqqna1g6pz"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)