summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm61
1 files changed, 60 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c1550550a7..738bdd3353 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -18,7 +18,8 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages linux)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses)
+ #:hide (zlib))
#:use-module (gnu packages)
#:use-module ((gnu packages compression)
#:renamer (symbol-prefix-proc 'guix:))
@@ -755,3 +756,61 @@ Packets are forwarded based on Ethernet address, rather than IP address (like
a router). Since forwarding is done at Layer 2, all protocols can go
transparently through a bridge.")
(license gpl2+)))
+
+(define-public libnl
+ (package
+ (name "libnl")
+ (version "3.2.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.infradead.org/~tgr/libnl/files/libnl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ydw42lsd572qwrfgws97n76hyvjdpanwrxm03lysnhfxkna1ssd"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("flex" ,flex) ("bison" ,bison)))
+ (home-page "http://www.infradead.org/~tgr/libnl/")
+ (synopsis "NetLink protocol library suite")
+ (description
+ "The libnl suite is a collection of libraries providing APIs to netlink
+protocol based Linux kernel interfaces. Netlink is an IPC mechanism primarly
+between the kernel and user space processes. It was designed to be a more
+flexible successor to ioctl to provide mainly networking related kernel
+configuration and monitoring interfaces.")
+
+ ;; Most files are LGPLv2.1-only, but some are GPLv2-only (like
+ ;; 'nl-addr-add.c'), so the result is GPLv2-only.
+ (license gpl2)))
+
+(define-public powertop
+ (package
+ (name "powertop")
+ (version "2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://01.org/powertop/sites/default/files/downloads/powertop-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "02rwqbpasdayl201v0549gbp2f82rd0hqiv3i111r7npanjhhb4b"))))
+ (build-system gnu-build-system)
+ (inputs
+ ;; TODO: Add pciutils.
+ `(("zlib" ,guix:zlib)
+ ("pkg-config" ,pkg-config)
+ ;; ("pciutils" ,pciutils)
+ ("ncurses" ,ncurses)
+ ("libnl" ,libnl)))
+ (home-page "https://01.org/powertop/")
+ (synopsis "Analyze power consumption on Intel-based laptops")
+ (description
+ "PowerTOP is a Linux tool to diagnose issues with power consumption and
+power management. In addition to being a diagnostic tool, PowerTOP also has
+an interactive mode where the user can experiment various power management
+settings for cases where the operating system has not enabled these
+settings.")
+ (license gpl2)))