summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm98
1 files changed, 70 insertions, 28 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0e81009059..a1a482f290 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -49,6 +49,8 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Anders Thuné <asse.97@gmail.com>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -349,7 +351,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernel. That is, the most recently released major
;; version.
-(define-public linux-libre-5.8-version "5.8.13")
+(define-public linux-libre-5.8-version "5.8.14")
(define deblob-scripts-5.8
(linux-libre-deblob-scripts
linux-libre-5.8-version
@@ -357,7 +359,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "0j6jba5fcddqlb42f95gjl78jisfla4nswqila074gglcrbnl9q7")))
(define-public linux-libre-5.8-pristine-source
(let ((version linux-libre-5.8-version)
- (hash (base32 "039j4ckx2p6rfpgqc5gzn6xc1krvhy0ivkjxck83s66xgqbkcngj")))
+ (hash (base32 "1bzh82jpwcxsdzp6p1r8qlq9v5x79flhnzyimkcll8wdh28pjxpf")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.8)))
@@ -365,7 +367,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.4-version "5.4.69")
+(define-public linux-libre-5.4-version "5.4.70")
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
linux-libre-5.4-version
@@ -373,12 +375,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "1b3q88i2qfdxyvpi9f7jds0qlb8hfpw87mgia096ax6822c2cmyb")))
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
- (hash (base32 "19vxsbwvfwyz1w6m7sp38d504w98zwjxaap4hfhh6wrrddqivcx8")))
+ (hash (base32 "01shqhibrxirl9bik8jwiag70n9n0l7782xh73gkb8jvbh4dicy0")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.4)))
-(define-public linux-libre-4.19-version "4.19.149")
+(define-public linux-libre-4.19-version "4.19.150")
(define deblob-scripts-4.19
(linux-libre-deblob-scripts
linux-libre-4.19-version
@@ -386,7 +388,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "1jiaw0as1ippkrjdpd52657w5mz9qczg3y2hlra7m9k0xawwiqlf")))
(define-public linux-libre-4.19-pristine-source
(let ((version linux-libre-4.19-version)
- (hash (base32 "001alvxgyb1n0fgbfi5dkzjviid32lyjfjwd3jwmcallcsdcpkfr")))
+ (hash (base32 "1kmsrinhy67vh34m6z3xinwg3v6z8jm7v1asq6rqqkba13phkxzj")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.19)))
@@ -1109,8 +1111,8 @@ RTL8812AU, RTL8821AU, and RTL8814AU chips.")
(license license:gpl2+))))
(define-public rtl8821ce-linux-module
- (let ((commit "69765eb288a8dfad3b055b906760b53e02ab1dea")
- (revision "0"))
+ (let ((commit "fe97b5003f2f3dd070f76ec38c00b83798c1cdea")
+ (revision "1"))
(package
(name "rtl8821ce-linux-module")
(version (git-version "0.0.0" revision commit))
@@ -1123,7 +1125,7 @@ RTL8812AU, RTL8821AU, and RTL8814AU chips.")
(file-name (git-file-name name version))
(sha256
(base32
- "17jiw25k74kv5lnvgycvj2g1n06hbrpjz6p4znk4a62g136rhn4s"))))
+ "10mrp63npbqb39c442vx8mra278hw7sczb3b6bjrpr3gan6ljshn"))))
(build-system linux-module-build-system)
(arguments
`(#:make-flags
@@ -7002,19 +7004,25 @@ the superuser to make device nodes.")
(define-public fakeroot
(package
(name "fakeroot")
- (version "1.24")
+ (version "1.25.1")
(source (origin
+ ;; There are no tags in the repository, so take this snapshot.
(method url-fetch)
(uri (string-append "https://deb.debian.org/debian/pool/main/f/"
"fakeroot/fakeroot_" version ".orig.tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1vb6f93hjyqnwx8dc8mm3dgma7axgqk8s7sdsjs8l2rpc0qmn11f"))))
+ "1ianaacwpjcw02shfiyybkqh5r6il4lvxin10n4y66kw0p7i3kcm"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; The "preroll" script takes care of Autoconf and also
+ ;; prepares the translated manuals.
+ (invoke "sh" "./preroll")))
(add-after 'configure 'patch-Makefile
(lambda _
;; Note: The root of the problem is already in "Makefile.am".
@@ -7054,21 +7062,21 @@ the superuser to make device nodes.")
;; We don't have an /etc/passwd entry for "root" - use numeric IDs.
(substitute* "test/compare-tar"
(("tar -tvf") "tar --numeric-owner -tvf"))
-
- ;; coreutils 8.32 changed 'ls' to use the statx() syscall instead
- ;; of lstat(). fakeroot 1.24 does not support the former, so
- ;; adjust these tests to use 'test -b' instead of 'ls' to test for
- ;; block device. See <https://bugs.gnu.org/41090>.
- (substitute* '("test/t.mknod" "test/t.chmod_dev")
- (("ls -ld? \\$tmp/hda3")
- "test -b $tmp/hda3 && echo block || echo fail"))
#t)))))
(native-inputs
- `(("acl" ,acl)
- ("sharutils" ,sharutils) ; for the tests
- ("xz" ,xz))) ; for the tests
+ `(;; For bootstrapping the package.
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("gettext" ,gettext-minimal)
+ ("po4a" ,po4a)
+
+ ;; For tests.
+ ("sharutils" ,sharutils)
+ ("xz" ,xz)))
(inputs
- `(("libcap" ,libcap/next)
+ `(("acl" ,acl)
+ ("libcap" ,libcap/next)
("util-linux" ,util-linux)
("sed" ,sed)
("coreutils" ,coreutils)))
@@ -7200,7 +7208,7 @@ of Linux application development.")
(package
(inherit pipewire)
(name "pipewire")
- (version "0.3.10")
+ (version "0.3.13")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7209,7 +7217,7 @@ of Linux application development.")
(file-name (git-file-name name version))
(sha256
(base32
- "1y293sfhhmzbgnlvs46bpiyimlii5nk71f8115qxs8sviwlsdr3w"))))
+ "19j5kmb7iaivkq2agfzncfm2qms41ckqi0ddxvhpc91ihwprdc5w"))))
(arguments
'(#:configure-flags
(list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
@@ -7373,9 +7381,8 @@ persistent over reboots.")
`(#:tests? #f ; no tests
#:make-flags
(list
- (string-append "PREFIX=''")
- (string-append "DESTDIR=" (assoc-ref %outputs "out"))
- (string-append "LIBDIR=/lib")
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "LIBDIR=$(PREFIX)/lib")
(string-append
"CC=" (assoc-ref %build-inputs "gcc") "/bin/gcc"))
#:phases
@@ -7586,3 +7593,38 @@ iptables rule and benefit from the speed of IP sets.
@end itemize\n
then IP sets may be the proper tool for you.")
(license license:gpl2+)))
+
+(define-public liburing
+ (package
+ (name "liburing")
+ (version "0.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.dk/liburing")
+ (commit (string-append "liburing-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15z44l7y4c6s6dlf7v8lq4znlsjbja2r4ifbni0l8cdcnq0w3zh3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(;; Tests are dependent on kernel version and features
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; configure fails if it is followed by SHELL, CONFIG_SHELL,
+ ;; --enable-fast-install, and --build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "SHELL" (which "sh"))
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (invoke "./configure" (string-append "--prefix=" out))))))))
+ (home-page "https://github.com/axboe/liburing")
+ (synopsis "Interface to the Linux kernel @code{io_uring} interface")
+ (description "This is the io_uring library, liburing. liburing provides
+helpers to setup and teardown io_uring instances, and also a simplified
+interface for applications that don't need (or want) to deal with the full
+kernel side implementation.")
+ (license license:expat)))