summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 47b07340b8..8b86531196 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -413,8 +413,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
It has been modified to remove all non-free binary blobs.")
(license license:gpl2)))
-(define %linux-libre-version "4.20.8")
-(define %linux-libre-hash "0qhwavylmkqqd84dym87ajzwnxc6rjpdijw7kbriqjmgjfsmf8sw")
+(define %linux-libre-version "4.20.10")
+(define %linux-libre-hash "0d386gb1s9ag80iqzms9gdsfzirq7nlkpkkx2d6ky01rv0g4vgqn")
(define %linux-libre-4.20-patches
(list %boot-logo-patch
@@ -427,8 +427,8 @@ It has been modified to remove all non-free binary blobs.")
#:patches %linux-libre-4.20-patches
#:configuration-file kernel-config))
-(define %linux-libre-4.19-version "4.19.21")
-(define %linux-libre-4.19-hash "064vwfkcmc8ad37m1ziqc14vhvx3mba12rc9220xng3a48gwpi2m")
+(define %linux-libre-4.19-version "4.19.23")
+(define %linux-libre-4.19-hash "0s207vqq2vcrgydjjwb5n2j7di0rjahnrbn3xv4xxlp5scjp59xq")
(define %linux-libre-4.19-patches
(list %boot-logo-patch
@@ -441,8 +441,8 @@ It has been modified to remove all non-free binary blobs.")
#:patches %linux-libre-4.19-patches
#:configuration-file kernel-config))
-(define %linux-libre-4.14-version "4.14.99")
-(define %linux-libre-4.14-hash "1d9h4l22j3jy1bkq8i4g6axwpq04jbsys4bg6bx8sbl590c9lrwx")
+(define %linux-libre-4.14-version "4.14.101")
+(define %linux-libre-4.14-hash "02j240x30zkhpazdimlfi0xq6zjdw6fidgdfrdnvfryvhf6j097j")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
@@ -451,8 +451,8 @@ It has been modified to remove all non-free binary blobs.")
#:configuration-file kernel-config))
(define-public linux-libre-4.9
- (make-linux-libre "4.9.156"
- "1ipmn5axlhfsfzqvwwyv7scrvfja39w7v68cnvbqiaq8fkjgffxg"
+ (make-linux-libre "4.9.158"
+ "11v56dzp87wyxrymf2s1cmk7jr440z11m3yan73rnnnqlfq460ig"
'("x86_64-linux" "i686-linux")
#:configuration-file kernel-config))
@@ -1839,20 +1839,19 @@ file system is as easy as logging into the server with an SSH client.")
(define-public archivemount
(package
(name "archivemount")
- (version "0.8.9")
+ (version "0.8.12")
(source
(origin
(method url-fetch)
- (uri (string-append "http://www.cybernoia.de/software/archivemount/"
+ (uri (string-append "https://www.cybernoia.de/software/archivemount/"
"archivemount-" version ".tar.gz"))
(sha256
- (base32
- "0v4si1ri6lhnq9q87gkx7fsh6lv6xz4bynknwndqncpvfp5cy1jg"))))
+ (base32 "12fb8fcmd1zwvfgzx4pay47md5cr2kgxcgq82cm6skmq75alfzi4"))))
(build-system gnu-build-system)
(inputs `(("fuse" ,fuse)
("libarchive" ,libarchive)))
(native-inputs `(("pkg-config" ,pkg-config)))
- (home-page "http://www.cybernoia.de/software/archivemount")
+ (home-page "https://www.cybernoia.de/software/archivemount.html")
(synopsis "Tool for mounting archive files with FUSE")
(description "archivemount is a FUSE-based file system for Unix variants,
including Linux. Its purpose is to mount archives (i.e. tar, tar.gz, etc.) to a
@@ -3699,7 +3698,7 @@ The collection contains a set of bandwidth and latency benchmark such as:
(package
(name "rng-tools")
(home-page "https://github.com/nhorman/rng-tools")
- (version "6.6")
+ (version "6.7")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page)
@@ -3707,11 +3706,12 @@ The collection contains a set of bandwidth and latency benchmark such as:
(file-name (git-file-name name version))
(sha256
(base32
- "0c32sxfvngdjzfmxn5ngc5yxwi8ij3yl216nhzyz9r31qi3m14v7"))))
+ "19f75m6mzg8h7b4snzg7d6ypvkz6nq32lrpi9ja95gqz4wsd18a5"))))
(build-system gnu-build-system)
(arguments
`(;; Avoid using OpenSSL, curl, and libxml2, reducing the closure by 166 MiB.
- #:configure-flags '("--without-nistbeacon")))
+ #:configure-flags '("--without-nistbeacon"
+ "--without-pkcs11")))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)