summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 52c7c7d027..66583dd253 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1661,16 +1661,17 @@ time.")
(inputs
`(("udev" ,eudev)))
(arguments
- '(#:phases (alist-cons-after
- 'configure 'set-makefile-shell
- (lambda _
- ;; Use 'sh', not 'bash', so that '. lib/utils.sh' works as
- ;; expected.
- (setenv "SHELL" (which "sh"))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'set-makefile-shell
+ (lambda _
+ ;; Use 'sh', not 'bash', so that '. lib/utils.sh' works as
+ ;; expected.
+ (setenv "SHELL" (which "sh"))
- ;; Replace /bin/sh with the right file name.
- (patch-makefile-SHELL "make.tmpl"))
- %standard-phases)
+ ;; Replace /bin/sh with the right file name.
+ (patch-makefile-SHELL "make.tmpl")
+ #t)))
#:configure-flags (list (string-append "--sysconfdir="
(assoc-ref %outputs "out")