summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b3354d1100..08a3995c9c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7731,6 +7731,31 @@ file systems.")
;; licensed under lgpl2.1. the other stuff is licensed under gpl2.
(license (list license:gpl2 license:lgpl2.1))))
+(define-public xfsprogs/static
+ (package
+ (inherit xfsprogs)
+ (name "xfsprogs-static")
+ (outputs (list "out"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments xfsprogs)
+ ((#:make-flags make-flags ''())
+ `(cons* "LLDFLAGS=-all-static" ,make-flags))
+ ((#:phases _ ''())
+ `(modify-phases %standard-phases
+ (add-after 'install 'delete-useless-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion (assoc-ref outputs "out")
+ (for-each delete-file-recursively
+ (list "include" "lib")))))))))
+ (inputs
+ `(("libinih:static" ,libinih "static")
+ ("util-linux:static" ,util-linux "static")
+ ,@(remove (match-lambda
+ ((label . _)
+ (member label '("python"))))
+ (package-inputs xfsprogs))))
+ (synopsis "Statically linked XFS file system tools")))
+
(define-public genext2fs
(package
(name "genext2fs")