summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 2ef813907d..7f437e425e 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -540,6 +540,17 @@ library primarily intended for language guessing.")
(sha256 (base32
"1b1lvqh68rwij1yvmxy02hsmh7i74ma5767mk8mg5nx6chajshhf"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'build 'adjust-for-ICU-65
+ (lambda _
+ ;; Fix build with ICU 65 and later. Taken from this
+ ;; upstream commit, remove for libfreehand > 0.1.2:
+ ;; https://gerrit.libreoffice.org/#/c/80224/
+ (substitute* "src/lib/libfreehand_utils.cpp"
+ (("U16_NEXT.*" all)
+ (string-append all ";\n")))
+ #t)))))
(native-inputs
`(("cppunit" ,cppunit)
("doxygen" ,doxygen)