summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm36
1 files changed, 25 insertions, 11 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 0dcdf46ff1..ab75650481 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
-;;; Copyright © 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
@@ -272,8 +272,16 @@ into other word processors.")
(uri (string-append "mirror://sourceforge/libebook/libe-book-"
version "/libe-book-" version ".tar.xz"))
(sha256
- (base32
- "1yg1vws1wggzhjw672bpgh2x541g5i9wryf67g51m0r79zrqz3by"))))
+ (base32
+ "1yg1vws1wggzhjw672bpgh2x541g5i9wryf67g51m0r79zrqz3by"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; This can be removed with the next release.
+ ;; Needed for icu4c compatibility >= 68.0.
+ (substitute* "src/lib/EBOOKCharsetConverter.cpp"
+ (("TRUE, TRUE, &status")
+ "true, true, &status"))))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
@@ -545,7 +553,8 @@ library primarily intended for language guessing.")
"1b1lvqh68rwij1yvmxy02hsmh7i74ma5767mk8mg5nx6chajshhf"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ '(#:configure-flags '("--disable-werror")
+ #:phases (modify-phases %standard-phases
(add-before 'build 'adjust-for-ICU-65
(lambda _
;; Fix build with ICU 65 and later. Taken from this
@@ -583,7 +592,15 @@ Aldus/Macromedia/Adobe FreeHand documents.")
(uri (string-append "https://dev-www.libreoffice.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256 (base32
- "1fhkn013gzg59f4z7rldpbi0nj7lgdqzxanspsqa6axvmahw2dpg"))))
+ "1fhkn013gzg59f4z7rldpbi0nj7lgdqzxanspsqa6axvmahw2dpg"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; This can be removed with the next release.
+ ;; https://gerrit.libreoffice.org/c/libmspub/+/73814
+ (substitute* "src/lib/MSPUBMetaData.h"
+ (("include <vector>" all)
+ (string-append all "\n#include <cstdint>")))))))
(build-system gnu-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -955,8 +972,8 @@ library.")
(myspell (string-append out "/share/myspell"))
(doc (string-append out "/share/doc/"
,name))
- (unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip")))
+ (unzip (search-input-file %build-inputs
+ "/bin/unzip")))
(invoke unzip "-j" "-o" (assoc-ref %build-inputs "source"))
(invoke unzip "-j" "-o" "pl_PL.zip")
(for-each (cut install-file <> hunspell)
@@ -1228,10 +1245,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(substitute* '("shell/source/unix/exec/shellexec.cxx"
"shell/source/unix/misc/senddoc.sh")
(("/usr/bin/xdg-open")
- (string-append (assoc-ref inputs "xdg-utils")
- "/bin/xdg-open")))
-
- #t))
+ (search-input-file inputs "/bin/xdg-open")))))
(add-after 'install 'reset-zip-timestamps
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))