summaryrefslogtreecommitdiff
path: root/gnu/packages/less.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/less.scm')
-rw-r--r--gnu/packages/less.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/less.scm b/gnu/packages/less.scm
index f6ee355b68..7c5107de09 100644
--- a/gnu/packages/less.scm
+++ b/gnu/packages/less.scm
@@ -80,7 +80,17 @@ text editors.")
(invoke "./configure"
(string-append "--prefix=" out)
"--yes")
- #t))))))
+ #t)))
+ (add-before 'install 'patch-tput-and-file
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "lesspipe.sh"
+ (("tput colors")
+ (string-append (assoc-ref inputs "ncurses")
+ "/bin/tput colors"))
+ (("file -")
+ (string-append (assoc-ref inputs "file")
+ "/bin/file -")))
+ #t)))))
(inputs
`(("file" ,file)
("ncurses" ,ncurses))) ; for tput