summaryrefslogtreecommitdiff
path: root/gnu/packages/kerberos.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kerberos.scm')
-rw-r--r--gnu/packages/kerberos.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index 20ed94b33b..5065f3be17 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,6 +42,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages readline)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module ((guix licenses) #:prefix license:)
@@ -52,7 +54,7 @@
(define-public mit-krb5
(package
(name "mit-krb5")
- (version "1.18")
+ (version "1.19.1")
(source (origin
(method url-fetch)
(uri (list
@@ -62,15 +64,17 @@
(string-append "https://kerberos.org/dist/krb5/"
(version-major+minor version)
"/krb5-" version ".tar.gz")))
- (patches (search-patches "mit-krb5-qualify-short-hostnames.patch"
- "mit-krb5-hurd.patch"))
+ (patches (search-patches "mit-krb5-hurd.patch"))
(sha256
(base32
- "121c5xsy3x0i4wdkrpw62yhvji6virbh6n30ypazkp0isws3k4bk"))))
+ "02xjpsfy84l6v7vjlxzhrl6mx2zrmxz0v01w2j33bv73nxzgh5ps"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
- ("perl" ,perl)))
+ ("perl" ,perl)
+ ("tcl" ,tcl))) ;required for some tests
+ (inputs
+ `(("openssl" ,openssl)))
(arguments
`(;; XXX: On 32-bit systems, 'kdb5_util' hangs on an fcntl/F_SETLKW call
;; while running the tests in 'src/tests'. Also disable tests when
@@ -94,20 +98,14 @@
(modify-phases %standard-phases
(add-after 'unpack 'enter-source-directory
(lambda _
- (chdir "src")
- #t))
+ (chdir "src")))
(add-before 'check 'pre-check
(lambda* (#:key inputs native-inputs #:allow-other-keys)
(let ((perl (assoc-ref (or native-inputs inputs) "perl")))
(substitute* "plugins/kdb/db2/libdb2/test/run.test"
(("/bin/cat") (string-append perl "/bin/perl"))
(("D/bin/sh") (string-append "D" (which "sh")))
- (("bindir=/bin/.") (string-append "bindir=" perl "/bin"))))
-
- ;; avoid service names since /etc/services is unavailable
- (substitute* "tests/resolve/Makefile"
- (("-p telnet") "-p 23"))
- #t)))))
+ (("bindir=/bin/.") (string-append "bindir=" perl "/bin")))))))))
(synopsis "MIT Kerberos 5")
(description
"Massachusetts Institute of Technology implementation of Kerberos.