summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm80
1 files changed, 68 insertions, 12 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index bf0cfd44e0..858b70a9c1 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
@@ -57,10 +57,12 @@
#:use-module (gnu packages ebook)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages geo)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gps)
#:use-module (gnu packages graphics)
#:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
@@ -74,6 +76,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages protobuf)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages tls)
@@ -709,17 +712,13 @@ different notification systems.")
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON"
"-DKDE_INSTALL_LIBEXECDIR=libexec")
- #:phases (modify-phases %standard-phases
- (add-after 'set-paths 'extend-CPLUS_INCLUDE_PATH
- (lambda* (#:key inputs #:allow-other-keys)
- ;; FIXME: <kcmutils_version.h> is not found during one
- ;; of the compilation steps without this hack.
- (setenv "CPLUS_INCLUDE_PATH"
- (string-append (assoc-ref inputs "kcmutils")
- "/include/KF5:"
- (or (getenv "CPLUS_INCLUDE_PATH")
- "")))
- #t)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'adjust-include-header
+ (lambda _
+ (substitute* "plugins/runcommand/runcommandplugin.cpp"
+ (("<kcmutils_version.h>")
+ "<KF5/kcmutils_version.h>")))))
#:tests? #f)) ; tests fail hard in our build environment
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -992,6 +991,63 @@ Python, PHP, and Perl.")
(description "Runtime library for kdegames")
(license (list license:gpl2+ license:fdl1.2+))))
+(define-public marble-qt
+ (package
+ (name "marble-qt")
+ (version "21.08.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://invent.kde.org/education/marble.git/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15gqym45z0gjzdc4ypfj0fki96c3dad4ygsi6lfr8yvwsx8swrb6"))))
+ (build-system qt-build-system)
+ (arguments
+ ;; FIXME: libmarblewidget-qt5.so.28 not found. Also enable the
+ ;; corresponding configure flag to build tests.
+ `(#:tests? #f
+ #:configure-flags
+ (list "-DBUILD_MARBLE_TOOLS=YES" ; file conversion tools
+ "-DBUILD_TOUCH=YES"
+ "-DBUILD_MARBLE_TESTS=FALSE")))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ ;; One optional dependency missing: libwlocate.
+ (inputs
+ `(("gpsd" ,gpsd)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdoctools" ,kdoctools)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("knewstuff" ,knewstuff)
+ ("kparts" ,kparts)
+ ("krunner" ,krunner)
+ ("kwallet" ,kwallet)
+ ("perl" ,perl)
+ ("phonon" ,phonon)
+ ("protobuf" ,protobuf)
+ ("qtbase" ,qtbase-5)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtlocation" ,qtlocation)
+ ("qtserialport" ,qtserialport)
+ ("qtsvg" ,qtsvg)
+ ;; ("qtwebengine" ,qtwebengine) ; FIXME: not found by CMake
+ ("shapelib" ,shapelib)
+ ("shared-mime-info" ,shared-mime-info)
+ ("zlib" ,zlib)))
+ (home-page "https://marble.kde.org/")
+ (synopsis "Virtual globe and world atlas")
+ (description "Marble is similar to a desktop globe. At closer scale it
+becomes a world atlas, while OpenStreetMap takes the user to street level. It
+supports searching for places of interest, viewing Wikipedia articles,
+creating routes by drag and drop and more.")
+ (license license:lgpl2.1+)))
+
(define-public okular
(package
(name "okular")