summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm152
1 files changed, 128 insertions, 24 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 1d14e4b820..d2ae91b179 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,8 +1,9 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2017 Mark Meyer <mark@ofosos.org>
+;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
(define-module (gnu packages kde)
#:use-module (guix build-system cmake)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -34,6 +36,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages graphics)
#:use-module (gnu packages image)
@@ -47,8 +50,87 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages video)
#:use-module (gnu packages xorg))
+(define-public kdenlive
+ (let ((version "18.08.1"))
+ (package
+ (name "kdenlive")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://anongit.kde.org/kdenlive.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (propagated-inputs
+ `(("mlt" ,mlt)))
+ (inputs
+ `(("shared-mime-info" ,shared-mime-info)
+ ("frei0r-plugins" ,frei0r-plugins)
+ ("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
+ ("qtsvg" ,qtsvg)
+ ("kparts" ,kparts)
+ ("knotifications" ,knotifications)
+ ("karchive" ,karchive)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kcrash" ,kcrash)
+ ("kguiaddons" ,kguiaddons)
+ ("knewstuff" ,knewstuff)
+ ("knotifyconfig" ,knotifyconfig)
+ ("kfilemetadata" ,kfilemetadata)
+ ("kdoctools" ,kdoctools)
+ ("kdeclarative", kdeclarative)
+ ("qtdeclarative", qtdeclarative)
+ ("qtquickcontrols", qtquickcontrols)
+ ("kiconthemes", kiconthemes)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("kplotting", kplotting)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
+ (qtbase (assoc-ref inputs "qtbase"))
+ (qtdeclarative (assoc-ref inputs "qtdeclarative"))
+ (frei0r (assoc-ref inputs "frei0r-plugins"))
+ (qml "/lib/qt5/qml"))
+ (wrap-program (string-append out "/bin/kdenlive")
+ `("QT_PLUGIN_PATH" ":" prefix
+ ,(map (lambda (label)
+ (string-append (assoc-ref inputs label)
+ "/lib/qt5/plugins/"))
+ '("qtbase", "qtsvg")))
+ `("FREI0R_PATH" ":" =
+ (,(string-append frei0r "/lib/frei0r-1/")))
+ `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
+ (,(string-append qtbase "/lib/qt5/plugins/platforms")))
+ `("QML2_IMPORT_PATH" ":" prefix
+ (,(string-append qtquickcontrols qml)
+ ,(string-append qtdeclarative qml)))))
+ #t)))))
+ (home-page "https://kdenlive.org")
+ (synopsis "Non-linear video editor")
+ (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
+
+Non-linear video editing is much more powerful than beginner's (linear)
+editors, hence it requires a bit more organization before starting. However,
+it is not reserved to specialists and can be used for small personal
+projects.")
+ (license license:gpl2+))))
+
(define-public kdevelop
(package
(name "kdevelop")
@@ -236,7 +318,7 @@ plugins, as well as code to create plugins, or complete applications.")
(define-public krita
(package
(name "krita")
- (version "4.0.1")
+ (version "4.1.5")
(source (origin
(method url-fetch)
(uri (string-append
@@ -245,7 +327,7 @@ plugins, as well as code to create plugins, or complete applications.")
"/" name "-" version ".tar.gz"))
(sha256
(base32
- "0k55ybvna40dx4fqygnix7bnhjaanak3ckb108hny2k7sspy62pc"))))
+ "1by8p8ifdp03f05bhg8ygdd1j036anfpjjnzbx63l2fbmy9k6q10"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f
@@ -316,7 +398,7 @@ plugins, as well as code to create plugins, or complete applications.")
("fftw" ,fftw)
("gsl" ,gsl)
("poppler-qt5" ,poppler-qt5)
- ("libraw" ,libraw)
+ ("libraw" ,libraw-0.18)
("libtiff" ,libtiff)
("perl" ,perl)
("ilmbase" ,ilmbase)
@@ -329,23 +411,6 @@ illustrators, matte and texture artists, and the VFX industry. Notable
features include brush stabilizers, brush engines and wrap-around mode.")
(license license:gpl2+)))
-;; Krita 3 and 4's file formats are incompatible, so we are keeping Krita 3
-;; for now.
-(define-public krita-3
- (package
- (inherit krita)
- (name "krita")
- (version "3.3.3")
- (source (origin
- (inherit (package-source krita))
- (uri (string-append
- "mirror://kde/stable/krita/"
- (version-prefix version 3)
- "/" name "-" version ".tar.gz"))
- (sha256
- (base32
- "0pc6hnakkqy81x5b5ncivaps6hqv43i50sjwgi3i3cz9j8rlxh5y"))))))
-
(define-public kholidays
(package
(name "kholidays")
@@ -415,10 +480,49 @@ used in KDE development tools Kompare and KDevelop.")
;; source archive
(license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
+(define-public libkscreen
+ (package
+ (name "libkscreen")
+ (version "5.13.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32 "04719va15i66qn1xqx318v6risxhp8bfcnhxh9mqm5h9qx5c6c4k"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ;; For testing.
+ ("dbus" ,dbus)))
+ (inputs
+ `(("kwayland" ,kwayland)
+ ("libxrandr" ,libxrandr)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (arguments
+ '(#:tests? #f ; FIXME: 55% tests passed, 5 tests failed out of 11
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; For the missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ ;; Run the tests offscreen.
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t)))))
+ (home-page "https://community.kde.org/Solid/Projects/ScreenManagement")
+ (synopsis "KDE's screen management software")
+ (description "KScreen is the new screen management software for KDE Plasma
+Workspaces which tries to be as magic and automatic as possible for users with
+basic needs and easy to configure for those who want special setups.")
+ (license license:gpl2+)))
+
(define-public libksysguard
(package
(name "libksysguard")
- (version "5.11.5")
+ (version "5.13.4")
(source
(origin
(method url-fetch)
@@ -426,7 +530,7 @@ used in KDE development tools Kompare and KDevelop.")
"/libksysguard-" version ".tar.xz"))
(sha256
(base32
- "0f2py4zkqzpxxf3mqaij0q8ka0v3nschj17dv6rbzzmr5mjv825f"))))
+ "0k8q5bxk9zyv7c3nny1c399v8acqs618nw39q20pj2qdijl9ibvh"))))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)))
@@ -468,7 +572,7 @@ used in KDE development tools Kompare and KDevelop.")
(lambda _
;; TODO: Fix this failing test-case
(zero? (system* "ctest" "-E" "processtest")))))))
- (home-page "https://www.kde.org/info/plasma-5.11.5.php")
+ (home-page "https://www.kde.org/info/plasma-5.13.4.php")
(synopsis "Network enabled task and system monitoring")
(description "KSysGuard can obtain information on system load and
manage running processes. It obtains this information by interacting