summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm51
1 files changed, 49 insertions, 2 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index cb24f0efbf..569ac43d91 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -308,7 +309,10 @@ wrapping notes into KMime::Message objects.")
(base32 "16qzs2cs4nxwrpwcdgwry95qn6wmg8s1p4w3qajx1ahkgwmsh11s"))))
(build-system qt-build-system)
(native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+
+ ;; For tests.
+ ("dbus" ,dbus)))
(inputs
`(("akonadi" ,akonadi)
("akonadi-mime" ,akonadi-mime)
@@ -327,7 +331,19 @@ wrapping notes into KMime::Message objects.")
("qtbase" ,qtbase)
("xapian" ,xapian)))
(arguments
- `(#:tests? #f)) ;; TODO: needs dbus
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ ;; FIXME: This test fails because it fails to establish
+ ;; a socket connection, seemingly due to failure during
+ ;; DBus communication.
+ (substitute* "agent/autotests/CMakeLists.txt"
+ ((".*schedulertest\\.cpp.*")
+ ""))
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "dbus-launch" "ctest"))))))
(home-page "https://api.kde.org/stable/kdepimlibs-apidocs/akonadi/html/")
(synopsis "Akonadi search library")
(description "This package provides a library used to search in the
@@ -1579,6 +1595,37 @@ and exchanging calendar data, vCalendar and iCalendar.")
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public kpeoplevcard
+ (package
+ (name "kpeoplevcard")
+ (version "0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.kde.org/stable/kpeoplevcard/"
+ version "/kpeoplevcard-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1hv3fq5k0pps1wdvq9r1zjnr0nxf8qc3vwsnzh9jpvdy79ddzrcd"))))
+ (build-system qt-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check-setup
+ (lambda _
+ (setenv "HOME" "/tmp")
+ #t)))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kcontacts" ,kcontacts)
+ ("kpeople" ,kpeople)
+ ("qtbase" ,qtbase)))
+ (home-page "https://invent.kde.org/pim/kpeoplevcard")
+ (synopsis "Expose vCard contacts to KPeople")
+ (description
+ "This plugins adds support for vCard (also known as @acronym{VCF,
+Virtual Contact File}) files to the KPeople contact management library.")
+ (license license:lgpl2.1+)))
+
(define-public kpimcommon
(package
(name "kpimcommon")