summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index d0e67fa37a..b63f72f071 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -90,10 +90,10 @@
#:phases
(modify-phases (@ (guix build qt-build-system) %standard-phases)
(add-before 'configure 'add-definitions
- (lambda _
- (let ((out (assoc-ref %outputs "out"))
- (mysql (assoc-ref %build-inputs "mysql"))
- (pgsql (assoc-ref %build-inputs "postgresql")))
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (mysql (assoc-ref inputs "mysql"))
+ (pgsql (assoc-ref inputs "postgresql")))
(with-output-to-file "CMakeLists.txt.new"
(lambda _
(display