summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index c67d0c393f..4857cf2354 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -71,6 +71,11 @@
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-lib-path
+ (lambda _
+ ;; Always install into /lib and not into /lib64.
+ (substitute* "kde-modules/KDEInstallDirs.cmake"
+ (("\"lib64\"") "\"lib\""))))
;; install and check phase are swapped to prevent install from failing
;; after testsuire has run
(add-after 'install 'check-post-install