summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6a48dc229a..ef304dd0df 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -33,6 +33,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages acl)
#:use-module (gnu packages admin)
@@ -294,12 +295,12 @@ http://freedesktop.org/wiki/Specifications/open-collaboration-services/")
;; TODO: qtdeclarative (yields one failing test)
`(("qtbase" ,qtbase-5)))
(arguments
- `(#:configure-flags
- (list (string-append
- "-DUDEV_RULES_INSTALL_DIR=" %output "/lib/udev/rules.d"))
- ;; TODO: Make tests pass: DBUS_FATAL_WARNINGS=0 still yields 7/8 tests
- ;; failing. When running after install, tests hang.
- #:tests? #f))
+ (list #:configure-flags
+ #~(list (string-append
+ "-DUDEV_RULES_INSTALL_DIR=" #$output "/lib/udev/rules.d"))
+ ;; TODO: Make tests pass: DBUS_FATAL_WARNINGS=0 still yields 7/8 tests
+ ;; failing. When running after install, tests hang.
+ #:tests? #f))
(home-page "https://community.kde.org/Frameworks")
(synopsis "QML wrapper for BlueZ")
(description "bluez-qt is a Qt-style library for accessing the bluez
@@ -457,9 +458,8 @@ GZip format, via a subclass of QIODevice.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "TZ" "Europe/Prague")
(setenv "TZDIR"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
- #t)))))
+ (search-input-directory inputs
+ "share/zoneinfo")))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Library for interfacing with calendars")
(description "This library provides access to and handling of calendar
@@ -1647,8 +1647,7 @@ integrated it into your application's other widgets.")
;; Xvfb doesn't have proper glx support and needs a pixeldepth
;; of 24 bit to avoid "libGL error: failed to load driver: swrast"
;; "Could not initialize GLX"
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 -screen 0 640x480x24 &"))
+ (system "Xvfb :1 -screen 0 640x480x24 &")
(setenv "DISPLAY" ":1")
#t)))))
(home-page "https://community.kde.org/Frameworks")
@@ -2392,8 +2391,7 @@ their settings.")
(lambda* (#:key inputs #:allow-other-keys)
;; The test suite requires a running X server, setting
;; QT_QPA_PLATFORM=offscreen does not suffice.
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 -screen 0 640x480x24 &"))
+ (system "Xvfb :1 -screen 0 640x480x24 &")
(setenv "DISPLAY" ":1")
#t)))))
(home-page "https://community.kde.org/Frameworks")
@@ -3069,12 +3067,12 @@ to easily extend the contacts collection.")
(add-after 'unpack 'fix-paths-for-test
;; This test tries to access paths like /home, /usr/bin and /bin/ls
;; which don't exist in the build-container. Change to existing paths.
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "autotests/runnercontexttest.cpp"
(("/home\"") "/tmp\"") ;; single path-part
(("//usr/bin\"") (string-append (getcwd) "\"")) ;; multiple path-parts
- (("/bin/ls" path)
- (string-append (assoc-ref %build-inputs "coreutils") path)))))
+ (("/bin/ls")
+ (search-input-file inputs "/bin/ls")))))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))
@@ -3697,8 +3695,8 @@ workspace.")
(lambda* (#:key inputs tests? #:allow-other-keys)
(setenv "HOME" (getcwd))
(setenv "TZDIR" ; KDateTimeTestsome needs TZDIR
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
+ (search-input-directory inputs
+ "share/zoneinfo"))
;; Make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
;; enable debug output