summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm175
1 files changed, 167 insertions, 8 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index e4be7efdd2..28c36d3037 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -137,6 +137,8 @@ ANSI escape codes to another format.")
(sha256
(base32 "1g0kyzcdykgs247j72jpc2qqall696jwgb3hnn4cxmbi8bkf7wpk"))))
(build-system julia-build-system)
+ (arguments
+ `(#:parallel-tests? #f))
(home-page "https://github.com/JuliaTesting/Aqua.jl")
(synopsis "Automated quality assurance for Julia packages")
(description "@acronym{Aqua.jl, Auto QUality Assurance for Julia packages},
@@ -157,6 +159,12 @@ provides functions to run a few automatable checks for Julia packages.")
(sha256
(base32 "0cmldnzvdgmfnrnrzgj6v1mfr2rvk5096392rwmhd3iyx7v0pq33"))))
(build-system julia-build-system)
+ (arguments
+ ;; XXXX: Unexpected failures for i686, e.g.,
+ ;; Expression: @inferred(ArrayInterface.size(Rnr)) === (StaticInt(4),)
+ ;; Evaluated: (static(2),) === (static(4),)
+ ;; Disable as stopgap.
+ `(#:tests? ,(not (target-x86-32?))))
(propagated-inputs
`(("julia-ifelse" ,julia-ifelse)
("julia-requires" ,julia-requires)
@@ -297,6 +305,25 @@ the entries on the bands.")
(sha256
(base32 "1xz3kdrphp4b158pg7dwkiry49phs2fjjpdvk1hjpww5ykxacks8"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-x86-32?)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests-i686
+ (lambda _
+ (substitute* "test/GroupsTests.jl"
+ (("@test sprint\\(show, g1\\)")
+ "@test_broken sprint(show, g1)")
+ (("@test sprint\\(show, g1; context = :boundto => 1\\)")
+ "@test_broken sprint(show, g1; context = :boundto => 1)")
+ (("@test sprint\\(show, g1; context = :limit => false\\)")
+ "@test_broken sprint(show, g1; context = :limit => false)")
+ (("@test @test_deprecated") "@test_broken"))
+ (substitute* "test/ExecutionTests.jl"
+ ;; Evaluated: 12 == 8
+ (("@test @ballocated\\(Ref\\(1\\)\\)")
+ "@test_broken @ballocated(Ref(1))"))))))
+ '(%standard-phases))))
(propagated-inputs `(("julia-json" ,julia-json)))
(home-page "https://github.com/JuliaCI/BenchmarkTools.jl")
(synopsis "Benchmarking framework for the Julia language")
@@ -319,6 +346,15 @@ benchmarks as well as comparing benchmark results.")
(sha256
(base32 "1by26036fk9mawmcgqxpwizgbs398v9p6vrbsgg7h6llqn3q9iw1"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-64bit?)
+ '(%standard-phases)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests-int32-i686
+ (lambda _
+ (substitute* "test/test_blockarrays.jl"
+ (("Int64") "Int32")))))))))
(propagated-inputs
`(("julia-arraylayouts" ,julia-arraylayouts)
("julia-fillarrays" ,julia-fillarrays)))
@@ -783,8 +819,7 @@ way.")
(add-after 'link-depot 'fix-tests
(lambda _
(substitute* "test/runtests.jl"
- (("option.toml") "test/option.toml"))
- #t))
+ (("option.toml") "test/option.toml"))))
(add-after 'link-depot 'dont-use-exproniconlite
(lambda _
(substitute* '("Project.toml"
@@ -793,8 +828,13 @@ way.")
(("ExproniconLite") "Expronicon"))
(substitute* "Project.toml"
(("55351af7-c7e9-48d6-89ff-24e801d99491")
- "6b7a57c9-7cc1-4fdf-b7f5-e857abae3636"))
- #t)))))
+ "6b7a57c9-7cc1-4fdf-b7f5-e857abae3636"))))
+ ,@(if (target-64bit?)
+ '()
+ '((add-after 'unpack 'fix-tests-int32-i686
+ (lambda _
+ (substitute* "test/runtests.jl"
+ (("Int64") "Int32")))))))))
(propagated-inputs
`(("julia-crayons" ,julia-crayons)
("julia-expronicon" ,julia-expronicon)
@@ -978,6 +1018,19 @@ Julia from R or Python.")
`(("julia-compat" ,julia-compat)
("julia-orderedcollections" ,julia-orderedcollections)))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-x86-32?)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-test-i686
+ (lambda _
+ ;; The evaluation returns the correct value,
+ ;; Evaluated: "Accumulator(1 => 3, 3 => 4)"
+ ;; but, for some reasons, is considered as failed.
+ (substitute* "test/test_accumulator.jl"
+ (("@test sprint\\(show,Accumulator\\(1 => 3, 3 => 4\\)\\)")
+ "@test_broken sprint(show, Accumulator(1 => 3, 3 => 4))"))))))
+ '(%standard-phases))))
(home-page "https://github.com/JuliaCollections/DataStructures.jl")
(synopsis "Julia module providing different data structures")
(description "This package implements a variety of data structures,
@@ -1650,6 +1703,17 @@ types and sparsity.")
(sha256
(base32 "09nsf9cgk49yrvprflnhd9h5rrgs280rgj8sad3csghxdx6jqk5c"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-x86-32?)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-test-i686
+ (lambda _
+ ;; Machine Precision incorrectly handled
+ (substitute* "test/methods.jl"
+ (("@test central_fdm\\(15, 5, adapt=2\\)\\(exp, 1.0\\)")
+ "@test_broken central_fdm(15, 5, adapt=2)(exp, 1.0)"))))))
+ '(%standard-phases))))
(inputs
`(("julia-benchmarktools" ,julia-benchmarktools)))
(propagated-inputs
@@ -1731,6 +1795,12 @@ c-style numerical formatting.")
(sha256
(base32 "1vb46x8mcn61g1l14qrk22c043khg2ml4q1ci7h4k2v34f2ak5fs"))))
(build-system julia-build-system)
+ (arguments
+ ;; XXXX: Unexpected and non-deterministic failures for i686, e.g.,
+ ;; Expression: dual_isapprox(FDNUM ^ PRIMAL, exp(PRIMAL * log(FDNUM)))
+ ;; ERROR: LoadError: LoadError: There was an error during testing
+ ;; Disable as stopgap.
+ `(#:tests? ,(not (target-x86-32?))))
(inputs ;required for tests
`(("julia-calculus" ,julia-calculus)
("julia-difftests" ,julia-difftests)))
@@ -1918,14 +1988,18 @@ matrices the Schur form is often more useful.")
(lambda _
(substitute* '("Project.toml"
"src/GeometryBasics.jl")
- ((".*EarCut.*") ""))
- #t))
+ ((".*EarCut.*") ""))))
(add-after 'link-depot 'skip-incompatible-test
(lambda _
(substitute* "test/runtests.jl"
(("@testset.*MetaT and heterogeneous data.*" all)
- (string-append all "return\n")))
- #t)))))
+ (string-append all "return\n")))))
+ ,@(if (target-64bit?)
+ '()
+ '((add-after 'unpack 'fix-tests-int32-i686
+ (lambda _
+ (substitute* "test/runtests.jl"
+ (("Int64") "Int32")))))))))
(propagated-inputs
`(("julia-itertools" ,julia-itertools)
("julia-staticarrays" ,julia-staticarrays)
@@ -2517,6 +2591,13 @@ interfaces with @file{.ini} files.")
(sha256
(base32 "1236c20k388qlh7k74mhf7hkbn0vf7ss8b1rgh1a6aj0234ayfnc"))))
(build-system julia-build-system)
+ (arguments
+ `(#:parallel-tests? #f
+ ;; XXXX: Unexpected failures for i686, e.g.,
+ ;; Got exception outside of a @test
+ ;; OverflowError: 96908232 * 106943408 overflowed for type Int32
+ ;; Disable as stopgap.
+ #:tests? ,(not (target-x86-32?))))
(propagated-inputs
`(("julia-axisalgorithms" ,julia-axisalgorithms)
("julia-offsetarrays" ,julia-offsetarrays)
@@ -2551,6 +2632,20 @@ and exceptional performance.")
(sha256
(base32 "0gsz89cd3iygbl5qr389k9vwpg7w1nk0s90g25nsmk34y9hifxag"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-x86-32?)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-test-i686
+ (lambda _
+ (substitute* "test/runtests.jl"
+ ;; For some reason, the output is correct but the test
+ ;; is considered as failed:
+ ;; Expression: duration(ClosedInterval(A, B)) ≡ 60
+ ;; Evaluated: 60 ≡ 60
+ (("@test duration\\(ClosedInterval")
+ "@test_broken duration(ClosedInterval"))))))
+ '(%standard-phases))))
(propagated-inputs
`(("julia-ellipsisnotation" ,julia-ellipsisnotation)))
(native-inputs
@@ -2776,6 +2871,15 @@ equations in string literals in the Julia language.")
(sha256
(base32 "17rhlrmgfvdw8w62pg32ikr9j4xy2ylr7mx7ar0hnpzryv929rp5"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-64bit?)
+ '(%standard-phases)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests-int32-i686
+ (lambda _
+ (substitute* "test/multests.jl"
+ (("Int64") "Int32")))))))))
(propagated-inputs
`(("julia-arraylayouts" ,julia-arraylayouts)
("julia-fillarrays" ,julia-fillarrays)
@@ -2852,6 +2956,15 @@ that let you do deep transformations of code.")
(sha256
(base32 "0l5adird8m1cmnsxwhzi5hcr7q9bm1rf7a6018zc7kcn2yxdshy3"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-64bit?)
+ '(%standard-phases)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests-int32-i686
+ (lambda _
+ (substitute* "test/runtests.jl"
+ (("Int64") "Int32")))))))))
(propagated-inputs
`(("julia-fixedpointnumbers" ,julia-fixedpointnumbers)))
(native-inputs
@@ -3169,6 +3282,22 @@ Julia, with type-driven, overloadable packing/unpacking functionality.")
(sha256
(base32 "1isyj8h4nx96cr6892d154v8pw1nhr7mjyz5bd6ffr2mkzb2bq4f"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-x86-32?)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-test-i686
+ (lambda _
+ (substitute* "test/utilities.jl"
+ ;; Non-deterministic returned value, e.g.,
+ ;; Expression: n == @allocated(f())
+ ;; Evaluated: 240 == 120
+ ;; and for some other values:
+ ;; Got correct result, please change to @test
+ ;; so @test_broken is not enough.
+ (("@test n == @allocated f\\(\\)")
+ " "))))))
+ '(%standard-phases))))
(propagated-inputs
`(("julia-offsetarrays" ,julia-offsetarrays)))
(home-page "https://github.com/jump-dev/MutableArithmetics.jl")
@@ -4005,6 +4134,8 @@ package can help create and update if need be.")
(sha256
(base32 "03hyfy7c0ma45b0y756j76awi3az2ii4bz4s8cxm3xw9yy1z7b01"))))
(build-system julia-build-system)
+ (arguments
+ `(#:parallel-tests? #f))
(inputs ;required for test
`(("julia-example" ,julia-example)))
(propagated-inputs
@@ -4031,6 +4162,12 @@ can be avoided.")
(sha256
(base32 "1wrr6sqj2xl9grkvdp88rw3manxy9vbx28zq2wssya5ns1xabsnl"))))
(build-system julia-build-system)
+ (arguments
+ ;; XXXX: Test suite failing for i686, e.g.,
+ ;; Expression: hash(tr_float, hash(1)) === hash(v_float, hash(1))
+ ;; MethodError: no method matching decompose(::ReverseDiff.TrackedReal{Float64, Float64, Nothing})
+ ;; Disable as stopgap.
+ `(#:tests? ,(not (target-x86-32?))))
(propagated-inputs
`(("julia-diffresults" ,julia-diffresults)
("julia-diffrules" ,julia-diffrules)
@@ -4540,6 +4677,16 @@ applied to any distance.")
(sha256
(base32 "0rjcpyjwzg70n87q5r9c5i1qzigavncslxssm3rk5a3y549py56v"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-64bit?)
+ '(%standard-phases)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests-int32-i686
+ (lambda _
+ (substitute* '("src/utils.jl"
+ "test/runtests.jl")
+ (("Int64") "Int32")))))))))
(propagated-inputs
`(("julia-dataapi" ,julia-dataapi)
("julia-staticarrays" ,julia-staticarrays)
@@ -4914,6 +5061,8 @@ working with @acronym{URIs,Uniform Resource Identifiers}, as defined in RFC
(sha256
(base32 "10qwscd15dnmvx116dwvg99m7kmwgmj5ahdkq7psiq48lcc554gq"))))
(build-system julia-build-system)
+ (arguments
+ `(#:parallel-tests? #f))
(propagated-inputs
`(("julia-constructionbase" ,julia-constructionbase)))
(home-page "https://painterqubits.github.io/Unitful.jl/stable/")
@@ -4984,6 +5133,16 @@ allows for efficient string representation and transfer")
(sha256
(base32 "04yykivi8zrbryxlmb0p5xa6lma8iq22r5s863117dnnqj5gaffd"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-x86-32?)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-test-i686
+ (lambda _
+ (substitute* "test/woodbury.jl"
+ (("@test logdet\\(W\\)")
+ "@test_broken logdet(W)"))))))
+ '(%standard-phases))))
(home-page "https://github.com/timholy/WoodburyMatrices.jl")
(synopsis "Support for the Woodbury matrix identity for Julia")
(description "This package provides support for the Woodbury matrix identity