summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index b3c1cb9814..6b36bc6f5e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2149,6 +2149,21 @@ feature-rich package implementing the client side of the most recent HTTP
standards and recommendations.")
(license license:asl2.0)))
+(define-public java-httpcomponents-httpmime
+ (package (inherit java-httpcomponents-httpclient)
+ (name "java-httpcomponents-httpmime")
+ (arguments
+ `(#:jar-name "httpcomponents-httpmime.jar"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "httpmime") #t)))))
+ (inputs
+ `(("java-httpcomponents-httpclient" ,java-httpcomponents-httpclient)
+ ("java-httpcomponents-httpcore" ,java-httpcomponents-httpcore)
+ ("java-junit" ,java-junit)
+ ("java-hamcrest-core" ,java-hamcrest-core)))))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")