summaryrefslogtreecommitdiff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/inkscape.scm')
-rw-r--r--gnu/packages/inkscape.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 9cab43c911..2e43835e4f 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -259,16 +259,6 @@ as the native format.")
(substitute-keyword-arguments (package-arguments inkscape/stable)
((#:phases phases)
`(modify-phases ,phases
- (add-after 'unpack 'disable-problematic-tests
- ;; The UnionOutside and UnionOutsideSwap tests fail, comparing
- ;; e.g. the result "M 0 1.5 V 0 H 2 V 2 H 0.5 V 2.5 H 0 V 2 V 1.5 H
- ;; 0.5 V 2 z" to the expected string "M 0 0 V 1.5 V 2 V 2.5 H 0.5 V
- ;; 2 H 2 V 0 z" (see:
- ;; https://gitlab.com/inkscape/inkscape/-/issues/3689).
- (lambda _
- (substitute* "testfiles/src/path-boolop-test.cpp"
- (("PathBoolopTest, UnionOutside(Swap)?.*" all)
- (string-append all " GTEST_SKIP();\n")))))
(replace 'wrap-program
;; Ensure Python is available at runtime.
(lambda* (#:key outputs #:allow-other-keys)
@@ -281,6 +271,7 @@ as the native format.")
`("GDK_PIXBUF_MODULE_FILE" =
(,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))))
(inputs (modify-inputs (package-inputs inkscape/stable)
+ (replace "lib2geom" lib2geom-1.2)
(append bash-minimal
librsvg))) ;for the pixbuf loader
(properties (alist-delete 'hidden? (package-properties inkscape/stable)))))