summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm82
1 files changed, 65 insertions, 17 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index b665740ca2..7b1d41cfa5 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
@@ -238,10 +240,6 @@ APNG patch provides APNG support to libpng.")
images. It can further losslessly compress them by as much as 40%.")
(license license:zlib)))
-(define-public pngcrunch
- ;; This package used to be wrongfully name "pngcrunch".
- (deprecated-package "pngcrunch" pngcrush))
-
(define-public pnglite
(let ((commit "11695c56f7d7db806920bd9229b69f230e6ffb38")
(revision "1"))
@@ -1305,7 +1303,7 @@ ISO/IEC 15444-1).")
(commit (string-append "release-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "12bs2rfmmy021087i10vxibdbbvd5vld0vk3h5hymhpz7rgszcmg"))))
+ (base32 "1dqyrq3p8bkgvj4ci50ac342hjnhyz6xxvhiwp7wpi3v3nbj7s02"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -1603,7 +1601,7 @@ medical image data, e.g. magnetic resonance image (MRI) and functional MRI
(build-system scons-build-system)
(native-inputs
`(("boost" ,boost)
- ("gettext" ,gnu-gettext)
+ ("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(inputs
`(("expat" ,expat)
@@ -1944,7 +1942,7 @@ This package can be used to create @code{favicon.ico} files for web sites.")
(define-public libavif
(package
(name "libavif")
- (version "0.5.6")
+ (version "0.7.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1953,7 +1951,7 @@ This package can be used to create @code{favicon.ico} files for web sites.")
(file-name (git-file-name name version))
(sha256
(base32
- "15g76j9vb88q1v3azscph8im8714zdl70bni0al4ww9v80vhqpkd"))))
+ "1xybjbbprvfsrwgysrn7grg6yp7v6ch5vci7zvdcdzcgyrbph172"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DAVIF_CODEC_AOM=ON" "-DAVIF_CODEC_DAV1D=ON"
@@ -1961,18 +1959,15 @@ This package can be used to create @code{favicon.ico} files for web sites.")
"-DAVIF_BUILD_TESTS=ON")
#:phases
(modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "./aviftest" "../source/tests/data")))
(add-after 'install 'install-readme
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/libavif-"
- ,version)))
- (install-file "../source/README.md" doc)))))
-;; The test suite runs tests for all supported codecs and fails because we don't
-;; have rav1e yet.
-;; (replace 'check
-;; (lambda _
-;; (invoke "./aviftest" "../source/tests/data"))))
- #:tests? #f))
+ (doc (string-append out "/share/doc/libavif-" ,version)))
+ (install-file "../source/README.md" doc)
+ #t))))))
(inputs
`(("libaom" ,libaom)
("dav1d" ,dav1d)))
@@ -1983,3 +1978,56 @@ AOM, including with alpha.")
(home-page "https://github.com/AOMediaCodec/libavif")
(license (list license:bsd-2 ; libavif itself
license:expat)))) ; cJSON in the test suite
+
+(define-public mtpaint
+ (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
+ (revision "1"))
+ (package
+ (name "mtpaint")
+ ;; The author neither releases tarballs nor uses git version tags.
+ ;; Instead, author puts version in git commit title.
+ (version (git-version "3.49.25" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wjaguar/mtPaint/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("imlib2" ,imlib2)
+ ("libtiff" ,libtiff)
+ ("libpng" ,libpng)
+ ("libungif", libungif)
+ ("libjpeg", libjpeg)
+ ("libwebp" ,libwebp)
+ ("openjpeg" ,openjpeg)
+ ("lcms" ,lcms)
+ ("zlib", zlib)
+ ("glib" ,glib)
+ ;; support for gtk3 is in testing stage
+ ("gtk+" ,gtk+-2)))
+ (arguments
+ `(#:configure-flags
+ (list
+ ;; internationalized version
+ "intl"
+ ;; install man page
+ "man")
+ ;; no check target
+ #:tests? #f))
+ (home-page "http://mtpaint.sourceforge.net/")
+ (synopsis "Create pixel art and manipulate digital images")
+ (description
+ "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
+It can create and edit indexed palette or 24bit RGB images, offers basic
+painting and palette manipulation tools. It also handles JPEG, JPEG2000,
+GIF, TIFF, WEBP, BMP, PNG, XPM formats.")
+ (license license:gpl3+))))