summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index cee7f146fa..23ad59ce9a 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -271,7 +271,9 @@ work.")
(string-append "mirror://sourceforge/openjpeg.mirror/" name "-"
version ".tar.gz"))
(sha256
- (base32 "00zzm303zvv4ijzancrsb1cqbph3pgz0nky92k9qx3fq9y0vnchj"))))
+ (base32 "00zzm303zvv4ijzancrsb1cqbph3pgz0nky92k9qx3fq9y0vnchj"))
+ (patches (map search-patch '("openjpeg-use-after-free-fix.patch"
+ "openjpeg-CVE-2015-6581.patch")))))
(build-system cmake-build-system)
(arguments
;; Trying to run `$ make check' results in a no rule fault.
@@ -292,7 +294,7 @@ In addition to the basic codec, various other features are under
development, among them the JP2 and MJ2 (Motion JPEG 2000) file formats,
an indexing tool useful for the JPIP protocol, JPWL-tools for
error-resilience, a Java-viewer for j2k-images, ...")
- (home-page "https://code.google.com/p/openjpeg/")
+ (home-page "https://github.com/uclouvain/openjpeg")
(license license:bsd-2)))
(define-public openjpeg-2.0
@@ -306,7 +308,9 @@ error-resilience, a Java-viewer for j2k-images, ...")
(string-append "mirror://sourceforge/openjpeg.mirror/" name "-"
version ".tar.gz"))
(sha256
- (base32 "1c2xc3nl2mg511b63rk7hrckmy14681p1m44mzw3n1fyqnjm0b0z"))))))
+ (base32 "1c2xc3nl2mg511b63rk7hrckmy14681p1m44mzw3n1fyqnjm0b0z"))
+ (patches (map search-patch '("openjpeg-use-after-free-fix.patch"
+ "openjpeg-CVE-2015-6581.patch")))))))
(define-public openjpeg-1
(package (inherit openjpeg)
@@ -457,17 +461,18 @@ supplies a generic doubly-linked list and some string functions.")
(define-public freeimage
(package
(name "freeimage")
- (version "3.16.0")
+ (version "3.17.0")
(source (origin
(method url-fetch)
(uri (string-append
"mirror://sourceforge/freeimage/Source%20Distribution/"
version "/FreeImage"
- (string-join (string-split version #\.) "")
+ (string-concatenate (string-split version #\.))
".zip"))
(sha256
(base32
- "0q1gnjnxgphsh4l8i9rfly4bi8xsczsb9ryzbm8hf38lc3fk5bq3"))))
+ "12bz57asdcfsz3zr9i9nska0fb6h3z2aizy412qjqkixkginbz7v"))
+ (patches (list (search-patch "freeimage-CVE-2015-0852.patch")))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-delete