summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm40
1 files changed, 28 insertions, 12 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index b059f314db..d1d6e2910b 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@@ -20,6 +20,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
@@ -301,7 +302,7 @@ actions.")
(define-public geeqie
(package
(name "geeqie")
- (version "1.5")
+ (version "1.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -309,13 +310,29 @@ actions.")
(commit (string-append "v" version))))
(sha256
(base32
- "0nf45sh3pwsv98sppcrqj81b6mdi31n1sbc7gn88m8mhpfp1qq6k"))
+ "1i9yd8lddp6b9s9vjjjzbpqj4bvwidxc6kiba6vdrk7dda5akyky"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `( ;; Enable support for a "map" pane using GPS data.
- #:configure-flags '("--enable-map"
- "--enable-gtk3")))
+ ;; Enable support for a "map" pane using GPS data.
+ `(#:configure-flags '("CFLAGS=-fcommon"
+ "--enable-map"
+ "--enable-gtk3")
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'correctly-locate-aux-scripts
+ ;; The git checkout has symlinks under the auxdir
+ ;; directory pointing to /usr/share/automake-1.16/depcomp
+ ;; and /usr/share/automake-1.16/install-sh, which causes
+ ;; the configure phase to fail (see:
+ ;; https://github.com/BestImageViewer/geeqie/issues/936).
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((automake (assoc-ref inputs "automake")))
+ (delete-file "auxdir/depcomp")
+ (symlink (car (find-files automake "depcomp"))
+ "auxdir/depcomp")
+ (delete-file "auxdir/install-sh")
+ (symlink (car (find-files automake "install-sh"))
+ "auxdir/install-sh")))))))
(inputs
`(("clutter" ,clutter)
("libchamplain" ,libchamplain)
@@ -326,7 +343,7 @@ actions.")
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("glib" ,glib "bin") ; glib-gettextize
+ ("glib" ,glib "bin") ; glib-gettextize
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(home-page "http://www.geeqie.org/")
@@ -615,10 +632,9 @@ It supports JPEG, PNG and GIF formats.")
;; not use 'OpenEXR.pc'. Thus, we need to add
;; "$ilmbase/include/OpenEXR/" to the CPATH.
(setenv "CPATH"
- (string-append (assoc-ref inputs "ilmbase")
- "/include/OpenEXR"
- ":" (or (getenv "CPATH") "")))
- #t)))))
+ (string-append
+ (search-input-directory inputs "include/OpenEXR")
+ ":" (or (getenv "CPATH") ""))))))))
(home-page "http://qtpfsgui.sourceforge.net")
(synopsis "High dynamic range (HDR) imaging application")
(description
@@ -829,7 +845,7 @@ displayed in a terminal.")
("libjpeg-turbo" ,libjpeg-turbo)
("libinih" ,libinih)
("libnsgif" ,libnsgif)
- ("librsvg" ,librsvg-next)
+ ("librsvg" ,librsvg)
("libtiff" ,libtiff)
("libxkbcommon" ,libxkbcommon)
("pango" ,pango)