summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index dfb68488ee..95fb90fdab 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -54,7 +54,7 @@
(define-public feh
(package
(name "feh")
- (version "2.20")
+ (version "2.21")
(home-page "https://feh.finalrewind.org/")
(source (origin
(method url-fetch)
@@ -62,13 +62,13 @@
name "-" version ".tar.bz2"))
(sha256
(base32
- "02vhdv16nf4kjna4inpbfy4k3p40bhl7xpc4kh4xvily14146l2b"))))
+ "0azgpr4al2pi4858z4xh4lfz84cvzxw3n426fn7rz6cdj34q212j"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-delete 'configure %standard-phases)
- #:tests? #f ;FIXME: Requires 'perl-test-command'.
- #:make-flags
- (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+ '(#:phases (modify-phases %standard-phases (delete 'configure))
+ #:tests? #f ;FIXME: Requires 'perl-test-command'.
+ #:make-flags
+ (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))))
(inputs `(("imlib2" ,imlib2)
("curl" ,curl)
("libpng" ,libpng)
@@ -178,9 +178,8 @@ It is the default image viewer on LXDE desktop environment.")
'(#:tests? #f ; no check target
#:make-flags (list (string-append "PREFIX=" %output)
"CC=gcc")
- #:phases (alist-delete
- 'configure ; no configure phase
- %standard-phases)))
+ ;; no configure phase
+ #:phases (modify-phases %standard-phases (delete 'configure))))
(inputs
`(("libx11" ,libx11)
("imlib2" ,imlib2)