summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm33
1 files changed, 27 insertions, 6 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 16dfebb1b7..bfa2fb4cf7 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,6 +58,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages geo)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gimp)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -161,7 +163,7 @@ licences similar to the Modified BSD licence."))))
("maxflow" ,maxflow)
("niftilib" ,niftilib)
("nlopt" ,nlopt)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("python-lxml" ,python2-lxml)
("vtk" ,vtk)))
(native-inputs
@@ -231,7 +233,7 @@ of external libraries that provide additional functionality.")
;; ocioconvert fails: error: conflicting declaration ?typedef void
;; (* PFNGLGETFRAGMENTMATERIALFVSGIXPROC)(GLenum, GLenum, GLfloat*)
`(("lcms" ,lcms)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("tinyxml" ,tinyxml)))
(home-page "https://opencolorio.org")
(synopsis "Color management for visual effects and animation")
@@ -635,7 +637,7 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
("libwebp" ,libwebp)
("zlib" ,zlib)
("gtkglext" ,gtkglext)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("ilmbase" ,ilmbase)
("gtk+" ,gtk+-2)
("python-numpy" ,python-numpy)
@@ -701,7 +703,7 @@ vision algorithms. It can be used to do things like:
("libwebp" ,libwebp)
("matio" ,matio)
("niftilib" ,niftilib)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("orc" ,orc)
("pango" ,pango)
("poppler" ,poppler)))
@@ -753,7 +755,7 @@ due to its architecture which automatically parallelises the image workflows.")
("libtiff" ,libtiff)
("libx11" ,libx11)
;;("opencv" ,opencv) ;OpenCV is currently broken in the CI
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("zlib" ,zlib)))
(home-page "https://gmic.eu/")
(synopsis "Full-featured framework for digital image processing")
@@ -801,6 +803,25 @@ including 2D color images.")
(assoc-ref %build-inputs "gmic") "/lib")))))
(synopsis "Krita plugin for the G'MIC image processing framework")))
+(define-public gmic-qt-gimp
+ (package
+ (inherit gmic-qt)
+ (name "gmic-qt-gimp")
+ (inputs
+ ;; GIMP and its dependencies.
+ `(("gimp" ,gimp)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("cairo" ,cairo)
+ ("gegl" ,gegl)
+ ,@(package-inputs gmic-qt)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments gmic-qt)
+ ((#:configure-flags flags)
+ '(list "-DGMIC_QT_HOST=gimp" "-DENABLE_DYNAMIC_LINKING=ON"
+ (string-append "-DGMIC_LIB_PATH="
+ (assoc-ref %build-inputs "gmic") "/lib")))))
+ (synopsis "GIMP plugin for the G'MIC image processing framework")))
+
(define-public nip2
(package
(name "nip2")
@@ -840,7 +861,7 @@ including 2D color images.")
("matio" ,matio)
("lcms" ,lcms)
("libwebp" ,libwebp)
- ("openexr" ,openexr)
+ ("openexr" ,openexr-2)
("poppler" ,poppler)
("gsl" ,gsl)))
(native-inputs