summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm66
1 files changed, 38 insertions, 28 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index a8968acba2..e708e1366c 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2018 Lprndn <guix@lprndn.info>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -59,36 +59,39 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages serialization)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (ice-9 match))
-;; We use the latest snapshot of this package because the latest release is
-;; from 2011 and has known vulnerabilities that cannot easily be fixed by
-;; applying patches.
(define-public dcmtk
(package
(name "dcmtk")
- (version "3.6.1_20170228")
- (source (origin
- (method url-fetch)
- (uri (string-append "ftp://dicom.offis.de/pub/dicom/offis/"
- "software/dcmtk/snapshot/dcmtk-"
- version ".tar.gz"))
- (sha256
- (base32
- "04cwfx8yrscqcd59mxk2fh6314ckayi9cp68iql5a57pf2pg5qld"))))
- (build-system gnu-build-system)
+ (version "3.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "ftp://dicom.offis.de/pub/dicom/offis/software/dcmtk/"
+ "dcmtk" (string-join (string-split version #\.) "")
+ "/dcmtk-" version ".tar.gz"))
+ (sha256
+ (base32 "1h22z8g0kmvhg8lgkbikyzyphhvxvq6018a00yd6i4g0z9ag6gx9"))))
+ (build-system cmake-build-system)
(inputs
- `(("libtiff" ,libtiff)
+ `(;; Our ICU is too recent: “error: ‘UChar’ does not name a type“.
+ ;; ("icu4c" ,icu4c)
+ ("libjpeg" ,libjpeg)
("libpng" ,libpng)
- ("doxygen" ,doxygen)
+ ("libtiff" ,libtiff)
+ ("libxml2" ,libxml2)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(native-inputs
- `(("perl" ,perl)))
- (home-page "http://dcmtk.org")
+ `(("doxygen" ,doxygen))) ; for HTML documentation
+ (home-page "https://dcmtk.org")
(synopsis "Libraries and programs implementing parts of the DICOM standard")
(description "DCMTK is a collection of libraries and applications
implementing large parts the DICOM standard. It includes software for
@@ -414,14 +417,15 @@ vision algorithms. It can be used to do things like:
(define-public vips
(package
(name "vips")
- (version "8.7.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/libvips/libvips/releases/download/v"
- version "/vips-" version ".tar.gz"))
- (sha256
- (base32 "1w3b90pdw7nj2p0gb4f96h6zhmga513f968ldfhz1rkhg7y81c0s"))))
+ (version "8.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/libvips/libvips/releases/download/v"
+ version "/vips-" version ".tar.gz"))
+ (sha256
+ (base32 "01gjhcrl6zj7mcj1al717v5jsniahplqhz1xkfh2j78vyfl1hxff"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -449,9 +453,15 @@ vision algorithms. It can be used to do things like:
("expat" ,expat)
("hdf5" ,hdf5)))
(home-page "https://libvips.github.io/libvips/")
- (synopsis "Image processing system")
+ (synopsis "Multithreaded image processing system with low memory needs")
(description
- "vips is a demand-driven, horizontally threaded image processing library.")
+ "VIPS is a demand-driven, horizontally threaded image processing library.
+It's particularly good at processing large images, working with colour,
+scientific analysis, and general research & development.
+
+Compared to most image processing libraries VIPS needs little RAM and runs
+quickly, especially on machines with more than one CPU core. This is primarily
+due to its architecture which automatically parallelises the image workflows.")
(license license:lgpl2.1+)))
(define-public nip2