summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 34c7c00f2d..c9f77d799a 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -46,20 +46,7 @@
#:use-module (gnu packages texinfo)
#:use-module (gnu packages onc-rpc)
#:use-module (gnu packages xorg) ; libpciaccess
- #:use-module (guix git-download)
- #:export (hurd-system?
- hurd-target?))
-
-(define (hurd-target?)
- "Return true if the cross-compilation target or the current system is
-GNU/Hurd."
- (or (and=> (%current-target-system) target-hurd?)
- (and (not (%current-target-system))
- (and=> (%current-system) target-hurd?))))
-
-(define (hurd-system?)
- "Return true if the current system is the Hurd."
- (and=> (%current-system) target-hurd?))
+ #:use-module (guix git-download))
(define (hurd-source-url version)
(string-append "mirror://gnu/hurd/hurd-"