summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 091e52323e..89709b8ffe 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4795,6 +4795,16 @@ unbounded @code{Integer} type.")
timer functions of different operating systems via a unified API.")
(license license:bsd-3)))
+;; This package builds `clock` without tests, since the tests rely on tasty
+;; and tasty-quickcheck, which in turn require clock to build.
+(define-public ghc-clock-bootstrap
+ (package
+ (inherit ghc-clock)
+ (name "ghc-clock-bootstrap")
+ (arguments '(#:tests? #f))
+ (inputs '())
+ (properties '((hidden? #t)))))
+
(define-public ghc-charset
(package
(name "ghc-charset")