summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 24 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6e19cd67ee..70929ddae6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2866,7 +2866,7 @@ with slicing and Clang-style colored diagnostics.")
;; re-enable them.
(arguments `(#:tests? #f))
(inputs
- `(("ghc-scientific" ,ghc-scientific)
+ `(("ghc-scientific-bootstrap" ,ghc-scientific-bootstrap)
("ghc-text" ,ghc-text)))
(native-inputs
`(("ghc-tasty" ,ghc-tasty)
@@ -2881,6 +2881,13 @@ aimed particularly at dealing efficiently with network protocols and
complicated text/binary file formats.")
(license license:bsd-3)))
+(define ghc-attoparsec-bootstrap
+ (package
+ (inherit ghc-attoparsec)
+ (name "ghc-attoparsec-bootstrap")
+ (arguments '(#:tests? #f))
+ (native-inputs '())))
+
(define-public ghc-zip-archive
(package
(name "ghc-zip-archive")
@@ -5208,6 +5215,13 @@ occurrences of a substring (the first in case of overlaps) with another.")
in migrated modules.")
(license license:expat)))
+(define ghc-integer-logarithms-bootstrap
+ (package
+ (inherit ghc-integer-logarithms)
+ (name "ghc-integer-logarithms-bootstrap")
+ (arguments `(#:tests? #f))
+ (native-inputs '())))
+
(define-public ghc-scientific
(package
(name "ghc-scientific")
@@ -5224,7 +5238,7 @@ in migrated modules.")
"03ql2f0ac8bsl524idy9xxa3kxisb2sj3avflzw580j5hzy0m397"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-integer-logarithms" ,ghc-integer-logarithms)
+ `(("ghc-integer-logarithms-bootstrap" ,ghc-integer-logarithms-bootstrap)
("ghc-text" ,ghc-text)
("ghc-hashable" ,ghc-hashable)
("ghc-primitive" ,ghc-primitive)))
@@ -5245,6 +5259,13 @@ and space efficient. They are represented using
notation}.")
(license license:bsd-3)))
+(define ghc-scientific-bootstrap
+ (package
+ (inherit ghc-scientific)
+ (name "ghc-scientific-bootstrap")
+ (arguments `(#:tests? #f))
+ (native-inputs '())))
+
(define-public ghc-boxes
(package
(name "ghc-boxes")
@@ -10168,7 +10189,7 @@ backends provided by the @code{Cairo} and @code{Diagrams} libraries.")
(inputs
`(("ghc-setlocale" ,ghc-setlocale)
("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-attoparsec" ,ghc-attoparsec)))
+ ("ghc-attoparsec-bootstrap" ,ghc-attoparsec-bootstrap)))
(home-page "https://github.com/solidsnack/wcwidth/")
(synopsis "Haskell bindings to wcwidth")
(description "This package provides Haskell bindings to your system's