summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ea51e02620..b497380008 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7328,4 +7328,29 @@ testing strategies.")
(description "More complex tests for @code{chell}.")
(license license:expat)))
+(define-public ghc-options
+ (package
+ (name "ghc-options")
+ (version "1.2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/options/options-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qjs0v1ny52w51n5582d4z8wy9h6n0zw1xb5dh686ff5wadflgi8"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-monads-tf" ,ghc-monads-tf)
+ ("ghc-chell" ,ghc-chell)
+ ("ghc-chell-quickcheck" ,ghc-chell-quickcheck)))
+ (home-page "https://john-millikin.com/software/haskell-options/")
+ (synopsis "Powerful and easy-to-use command-line option parser")
+ (description
+ "The @code{options} package lets library and application developers
+easily work with command-line options.")
+ (license license:expat)))
+
;;; haskell.scm ends here