summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 33c9c6484d..97b4fd9a55 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2018, 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018, 2019 Gabriel Hondet <gabrielhondet@gmail.com>
+;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1325,6 +1326,16 @@ postfix notation. For more information on stack based languages, see
(base32
"138xpxdb7x62lpmgmb6b3v3vgdqqvqn4273jaap3mjmc2gla709y"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-test-issue93
+ (lambda _
+ ;; Tests run out of memory on a system with 2GB of available RAM,
+ ;; in 'issue93.a.hs' and 'issue93.n.hs'.
+ (substitute* "tests/Makefile"
+ ((" issue93.y ") " "))
+ #t)))))
(home-page "https://hackage.haskell.org/package/happy")
(synopsis "Parser generator for Haskell")
(description "Happy is a parser generator for Haskell. Given a grammar
@@ -1794,7 +1805,7 @@ version 1.3).")
(define-public ghc-streaming-commons
(package
(name "ghc-streaming-commons")
- (version "0.2.1.0")
+ (version "0.2.1.1")
(source
(origin
(method url-fetch)
@@ -1803,7 +1814,7 @@ version 1.3).")
version ".tar.gz"))
(sha256
(base32
- "13fn6qmpiggwpn8lczyydgp77cyzfypwds7wxskrwir4i5cgxlfq"))))
+ "1lmyx3wkjsayhy5yilzvy0kf8qwmycwlk26r1d8f3cxbfhkr7s52"))))
(build-system haskell-build-system)
(inputs
`(("ghc-async" ,ghc-async)
@@ -6941,7 +6952,7 @@ upon it.")
(define-public ghc-conduit-extra
(package
(name "ghc-conduit-extra")
- (version "1.3.0")
+ (version "1.3.1.1")
(source
(origin
(method url-fetch)
@@ -6950,7 +6961,7 @@ upon it.")
version ".tar.gz"))
(sha256
(base32
- "1bi2b6kdzy5f9glq46jzsk02has95jkxqz0cchpbmnakzhjwjh9c"))))
+ "0jaj350vv6mbb26gdwcqz4gwzfzrjydv5pis2da49wz1npbakcfw"))))
(build-system haskell-build-system)
(inputs
`(("ghc-conduit" ,ghc-conduit)