summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm78
1 files changed, 76 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 94671ee54d..09732fc594 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
@@ -14,7 +14,7 @@
;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Tonton <tonton@riseup.net>
-;;; Copyright © 2018, 2019 Timothy Sample <samplet@ngyro.com>
+;;; Copyright © 2018, 2019, 2020 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018, 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
@@ -47,6 +47,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
+ #:use-module (gnu packages version-control)
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -567,6 +568,32 @@ interactive environment for the functional language Haskell.")
,make-flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
+ (add-after 'install 'remove-unnecessary-references
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* (find-files (string-append (assoc-ref outputs "out") "/lib/")
+ "settings")
+ (("/gnu/store/.*/bin/(.*)" m program) program))
+
+ ;; Remove references to "doc" output from "out" by rewriting
+ ;; the "haddock-interfaces" fields and removing the optional
+ ;; "haddock-html" field in the generated .conf files.
+ (let ((doc (assoc-ref outputs "doc"))
+ (out (assoc-ref outputs "out")))
+ (with-fluids ((%default-port-encoding #f))
+ (for-each (lambda (config-file)
+ (substitute* config-file
+ (("^haddock-html: .*") "\n")
+ (((format #f "^haddock-interfaces: ~a" doc))
+ (string-append "haddock-interfaces: " out))))
+ (find-files (string-append out "/lib") ".conf")))
+ ;; Move the referenced files to the "out" output.
+ (for-each (lambda (haddock-file)
+ (let* ((subdir (string-drop haddock-file (string-length doc)))
+ (new (string-append out subdir)))
+ (mkdir-p (dirname new))
+ (rename-file haddock-file new)))
+ (find-files doc "\\.haddock$")))
+ #t))
(add-after 'unpack-testsuite 'skip-tests
(lambda _
;; These two tests refer to the root user, which doesn't exist
@@ -583,6 +610,53 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
+(define-public ghc-8.8
+ (package (inherit ghc-8.6)
+ (name "ghc")
+ (version "8.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-src.tar.xz"))
+ (sha256
+ (base32 "128g932i3wix6ic03v04nh5755vyjiidzri9iybwad72yfmc1p70"))))
+ (native-inputs
+ `(("ghc-bootstrap" ,ghc-8.6)
+ ("ghc-testsuite"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-testsuite.tar.xz"))
+ (patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
+ (sha256
+ (base32
+ "1l32mp94ll72skfsq1g2fqax4bkiw8b85gr3wd0bbqsqyi9a9jpr"))))
+ ("git" ,git) ; invoked during tests
+ ,@(filter (match-lambda
+ (("ghc-bootstrap" . _) #f)
+ (("ghc-testsuite" . _) #f)
+ (_ #t))
+ (package-native-inputs ghc-8.6))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ghc-8.6)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-after 'unpack-testsuite 'skip-more-tests
+ (lambda _
+ ;; XXX: This test fails because our ld-wrapper script
+ ;; mangles the response file passed to the linker.
+ (substitute* "testsuite/tests/hp2ps/all.T"
+ (("^test\\('T15904'") "# guix skipped: test('T15904'"))
+ #t))))))
+ (native-search-paths (list (search-path-specification
+ (variable "GHC_PACKAGE_PATH")
+ (files (list
+ (string-append "lib/ghc-" version)))
+ (file-pattern ".*\\.conf\\.d$")
+ (file-type 'directory))))))
+
(define-public ghc-8 ghc-8.6)
(define-public ghc ghc-8)