summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 946948be99..e7276795a9 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10529,6 +10529,38 @@ datatypes reachable from an initial datatype, and passing these names to some
function which generates instances.")
(license license:bsd-3)))
+(define-public ghc-time-compat
+ (package
+ (name "ghc-time-compat")
+ (version "1.9.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "time-compat/time-compat-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05va0rqs759vbridbcl6hksp967j9anjvys8vx72fnfkhlrn2s52"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-base-orphans" ,ghc-base-orphans)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-tagged" ,ghc-tagged)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (arguments
+ `(#:cabal-revision
+ ("1" "0k8ph4sydaiqp8dav4if6hpiaq8h1xsr93khmdr7a1mmfwdxr64r")))
+ (home-page "https://github.com/phadej/time-compat")
+ (synopsis "Compatibility package for time")
+ (description "This packages tries to compat as many @code{time}
+features as possible.")
+ (license license:bsd-3)))
+
(define-public ghc-time-locale-compat
(package
(name "ghc-time-locale-compat")