summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index a24ee4b7c0..f1b50b29bd 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -866,3 +866,26 @@ of a JSON value into a @code{Data.Aeson.Value}.")
(description
"HTTP multipart split out of the cgi package, for Haskell.")
(license license:bsd-3)))
+
+(define-public ghc-uri-encode
+ (package
+ (name "ghc-uri-encode")
+ (version "1.5.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/uri-encode/uri-encode-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "11miwb5vvnn17m92ykz1pzg9x6s8fbpz3mmsyqs2s4b3mn55haz8"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-text" ,ghc-text)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-network-uri" ,ghc-network-uri)))
+ (home-page "https://hackage.haskell.org/package/uri-encode")
+ (synopsis "Unicode aware uri-encoding")
+ (description "Unicode aware uri-encoding for Haskell.")
+ (license license:bsd-3)))