summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index d6b171d5b3..b2d352050f 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -603,19 +603,21 @@ using Template Haskell")
(define-public ghc-hunit
(package
(name "ghc-hunit")
- (version "1.3.1.2")
+ (version "1.6.0.0")
(outputs '("out" "doc"))
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/HUnit/HUnit-"
- version
- ".tar.gz"))
+ (uri (string-append "https://hackage.haskell.org/package/HUnit/"
+ "HUnit-" version ".tar.gz"))
(sha256
(base32
- "10akdh4fl615rrshxi3m5gf414il1q42z4zqyb6q4jasmscvzpms"))))
+ "1pnhwqq5v8h48gbp3ibv3skfj25mf4zs5svxcavq93p9cswycj3l"))))
(build-system haskell-build-system)
+ (inputs
+ ;; We cannot use ghc-call-stack there, because it depends on
+ ;; ghc-nanospec, which depends on ghc-hunit.
+ `(("ghc-call-stack" ,ghc-call-stack-boot)))
(home-page "http://hunit.sourceforge.net/")
(synopsis "Unit testing framework for Haskell")
(description