summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm54
1 files changed, 35 insertions, 19 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index a3418878e7..3da6759472 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2021 Evgeny Pisemsky <evgeny@pisemsky.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
@@ -289,7 +291,7 @@ be dangerous and may void your CPU or system board's warranty.")
(define-public wavemon
(package
(name "wavemon")
- (version "0.9.2")
+ (version "0.9.3")
(source
(origin
(method git-fetch)
@@ -298,24 +300,7 @@ be dangerous and may void your CPU or system board's warranty.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0y984wm03lzqf7bk06a07mw7d1fzjsp9x7zxcvlx4xqmv7wlgb29"))
- (patches
- (list
- ;; Two upstream commits required to find the correct <ncurses.h>.
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/uoaerg/wavemon/commit/"
- "ce7f9c4da90767bb50e4b80cdb3cee61264d8d12.patch"))
- (sha256
- (base32 "04b4qbsa5l0jr41dkj0c8yw74lm8z8b50nw1iwas6hnzq41dwdm3")))
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/uoaerg/wavemon/commit/"
- "31e3def1c7332ad830bd966e7d21b343b4f2da54.patch"))
- (sha256
- (base32 "0kyv3sbkv9hl8b88xnk6bq550axh9wzfjlhp3jbvqd4fqf7663br")))))))
+ (base32 "0m9n5asjxs1ir5rqprigqcrm976mgjvh4yql1jhfnbszwbf95193"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -482,3 +467,34 @@ authorization policies (what kind of USB devices are authorized) as well as
method of use policies (how a USB device may interact with the system).
Simply put, it is a USB device whitelisting tool.")
(license license:gpl2)))
+
+(define-public screentest
+ (package
+ (name "screentest")
+ (version "2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TobiX/screentest")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gv3xj9sbk1wsyijfw9xjnvy8pg7j4arjnma2r2kfi18qy32wd30"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+-2)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("glib" ,glib "bin")
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Simple screen testing tool")
+ (description "This is a program for testing the quality of CRT/LCD
+screens. It displays various patterns and allows you to estimate the quality
+of your CRT/LCD monitor.")
+ (home-page "https://github.com/TobiX/screentest")
+ (license license:gpl2)))