summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm36
1 files changed, 32 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index d023ac7760..878857fe29 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -285,14 +285,14 @@ without requiring the source code to be rewritten.")
(package
(inherit guile-2.2)
(name "guile")
- (version "3.0.4")
+ (version "3.0.5")
(source (origin
(inherit (package-source guile-2.2))
(uri (string-append "mirror://gnu/guile/guile-"
version ".tar.xz"))
(sha256
(base32
- "0c8dkyvs6xbxp7rgnhkyakajzhakay7qn9kahj1mj49x5vf4fybb"))))
+ "1wah6fq1h8vmbpdadjych1mq8hyqkd7p015cbxm14ri37l1gnxid"))))
(arguments
;; XXX: JIT-enabled Guile crashes in obscure ways on GNU/Hurd.
(if (hurd-target?)
@@ -570,14 +570,14 @@ specification. These are the main features:
(package
(inherit guile-json-3)
(name "guile-json")
- (version "4.3.2")
+ (version "4.4.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/guile-json/guile-json-"
version ".tar.gz"))
(sha256
(base32
- "0255c7f053z4p9mqzhpxwbfx3y47j9nfvlgnm8xasdclyzmjl9y2"))))))
+ "1xq4f59rdk28xy4sdn6amy07aa19ikrk48iily3kfhwpkbg6v9jj"))))))
(define-public guile2.2-json
(package-for-guile-2.2 guile-json-4))
@@ -840,4 +840,32 @@ pure Scheme by using Guile's foreign function interface.")
(home-page "https://notabug.org/guile-lzlib/guile-lzlib")
(license license:gpl3+)))
+(define-public guile-zstd
+ (package
+ (name "guile-zstd")
+ (version "0.1.1")
+ (home-page "https://notabug.org/guile-zstd/guile-zstd")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c8l7829b5yx8wdc0mrhzjfwb6h9hb7cd8dfxcr71a7vlsi86310"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("guile" ,guile-3.0)))
+ (inputs
+ `(("zstd" ,zstd "lib")
+ ("guile" ,guile-3.0)))
+ (synopsis "GNU Guile bindings to the zstd compression library")
+ (description
+ "This package provides a GNU Guile interface to the zstd (``zstandard'')
+compression library.")
+ (license license:gpl3+)))
+
;;; guile.scm ends here