summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index fe043cba0b..53ea3e53bb 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 Erik Edrosa <erik.edrosa@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,7 +73,7 @@
(sha256
(base32
"0l200a0v7h8bh0cwz6v7hc13ds39cgqsmfrks55b1rbj5vniyiy3"))
- (patches (list (search-patch "guile-1.8-cpp-4.5.patch")))))
+ (patches (search-patches "guile-1.8-cpp-4.5.patch"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("--disable-error-on-warning")
@@ -132,7 +133,7 @@ without requiring the source code to be rewritten.")
(sha256
(base32
"1qh3j7308qvsjgwf7h94yqgckpbgz2k3yqdkzsyhqcafvfka9l5f"))
- (patches (list (search-patch "guile-arm-fixes.patch")))))
+ (patches (search-patches "guile-arm-fixes.patch"))))
(build-system gnu-build-system)
(native-inputs `(("pkgconfig" ,pkg-config)))
(inputs `(("libffi" ,libffi)
@@ -410,7 +411,7 @@ library.")
(sha256
(base32
"0zparwgf01jgl1x53ik71ghabldq6zz18ha4dscps1i0qrzgap1b"))
- (patches (list (search-patch "mcron-install.patch")))))
+ (patches (search-patches "mcron-install.patch"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("ed" ,ed) ("which" ,which) ("guile" ,guile-2.0)))
@@ -529,7 +530,7 @@ http:://json.org specification. These are the main features:
(setenv "GUILE_AUTO_COMPILE" "0")
(for-each (lambda (file)
(let* ((dest-file (string-append module-dir "/"
- file ".scm"))
+ file))
(go-file (match (string-split file #\.)
((base _)
(string-append module-dir "/"
@@ -711,14 +712,14 @@ Guile's foreign function interface.")
(define-public haunt
(package
(name "haunt")
- (version "0.1")
+ (version "0.2")
(source (origin
(method url-fetch)
- (uri (string-append "http://files.dthompson.us/haunt/haunt-"
+ (uri (string-append "https://files.dthompson.us/haunt/haunt-"
version ".tar.gz"))
(sha256
(base32
- "15q1qwjnay7k90ppqrzqsmikvwyj61mjvf1zahyd9gm4vi2fgb3x"))))
+ "1id83n8fs7jxys1d8jy70vylg8gzcvlw1y7hb41y3qxv5zi4671m"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 match) (ice-9 ftw)
@@ -742,8 +743,13 @@ Guile's foreign function interface.")
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
(,modules)))
#t)))))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
(inputs
`(("guile" ,guile-2.0)))
+ (propagated-inputs
+ `(("guile-reader" ,guile-reader)))
(synopsis "Functional static site generator")
(description "Haunt is a static site generator written in Guile
Scheme. Haunt features a functional build system and an extensible