summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm32
1 files changed, 21 insertions, 11 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 37add951ac..01a25abee9 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1159,9 +1159,7 @@ messaging library.")
;; command.
(substitute* "src/hmac.scm"
(("openssl")
- (string-append (assoc-ref inputs "openssl")
- "/bin/openssl")))
- #t))
+ (search-input-file inputs "/bin/openssl")))))
;; XXX: The code uses 'include' to include its own source
;; files, and "-L src" isn't enough in this case.
@@ -1283,7 +1281,9 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
version ".tar.lz"))
(sha256
(base32
- "1rc8r0fgvflnyq5ckl7ii8sghpsgpkzxa8vskjr1ak2kyar6m35k"))))
+ "1rc8r0fgvflnyq5ckl7ii8sghpsgpkzxa8vskjr1ak2kyar6m35k"))
+ (patches
+ (search-patches "guile-email-fix-tests.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -1787,6 +1787,9 @@ provides tight coupling to Guix.")
"GUILE_PKG([3.0 2.2 2.0])\n"))
#t))))
(build-system gnu-build-system)
+ ;; XXX: Tests expect 'test-runner-current' to not return #f after
+ ;; 'test-end', which is no longer the case in Guile 3.0.7.
+ (arguments '(#:tests? #f))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -2912,7 +2915,7 @@ chunks can be expressions as well as simple tokens.")
(("/usr/local/lib/guile")
(string-append (assoc-ref outputs "out") "/lib/guile"))
(("/usr/local/include/guile")
- (string-append (assoc-ref inputs "guile") "/include/guile"))
+ (search-input-directory inputs "/include/guile"))
(("-L/usr/local/lib")
(string-append "-L" (assoc-ref inputs "guile") "/lib")))
#t))
@@ -3318,7 +3321,7 @@ API.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)
- ("texlive" ,(texlive-union (list texlive-generic-epsf)))))
+ ("texlive" ,(texlive-updmap.cfg (list texlive-epsf)))))
(inputs
`(("dbus-glib" ,dbus-glib)
("guile" ,guile-3.0)
@@ -3602,7 +3605,7 @@ feature-set, fully programmable in Guile Scheme.")
("vigra-c" ,vigra-c)
("guile" ,guile-2.2)))
(native-inputs
- `(("texlive" ,(texlive-union (list texlive-booktabs
+ `(("texlive" ,(texlive-updmap.cfg (list texlive-booktabs
texlive-lm
texlive-siunitx
texlive-standalone
@@ -3990,7 +3993,14 @@ over, or update a value in arbitrary data structures.")
(file-name (git-file-name name version))
(sha256
(base32
- "16k61f1jn3g48jaf3730b9l0izr5j933jzyri73nmcnjd09gm35i"))))
+ "16k61f1jn3g48jaf3730b9l0izr5j933jzyri73nmcnjd09gm35i"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Guile >= 3.0.7 no longer uses libltdl so we need to explicitly add
+ ;; ".libs" so that 'load-extension' finds the '.so' file.
+ '(substitute* "pre-inst-env.in"
+ (("^LD_LIBRARY_PATH=.*$")
+ "LD_LIBRARY_PATH=\"$abs_top_builddir/.libs\"\n")))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
@@ -4531,12 +4541,12 @@ including parsing and code generation.")
(delete-file-recursively "docs")
#t))
(add-after 'install 'install-info-documentation
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((share (string-append (assoc-ref outputs "out") "/share"))
(doc (string-append share "/doc/" ,name "-" ,version))
(info (string-append share "/info/"))
- (makeinfo (string-append (assoc-ref %build-inputs "texinfo")
- "/bin/makeinfo")))
+ (makeinfo (search-input-file inputs
+ "/bin/makeinfo")))
(invoke makeinfo "guile-shapefile.texi" "-o" info)
#t))))))
(inputs