summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm35
1 files changed, 31 insertions, 4 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 089a9a3b55..67c6a7f125 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2021 Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1778,7 +1779,7 @@ user which package sets would they like to install from it.")
(define-public guile-wisp
(package
(name "guile-wisp")
- (version "1.0.3")
+ (version "1.0.5")
(source (origin
(method hg-fetch)
(uri (hg-reference
@@ -1787,7 +1788,7 @@ user which package sets would they like to install from it.")
(file-name (git-file-name name version))
(sha256
(base32
- "10g97jz3ahpb5mg933ajsc3pa9jxlg14f42yf01qwx0dwq1b06d5"))))
+ "00iknn03gf421gg3061g35fbraqrkcqypkrfn10rhlgg6j0lgk67"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -1854,7 +1855,8 @@ user which package sets would they like to install from it.")
(description "Wisp is a syntax for Guile which provides a Python-like
whitespace-significant language. It may be easier on the eyes for some
users and in some situations.")
- (license license:gpl3+)))
+ (license (list license:gpl3+ ; the project as a whole
+ license:expat)))) ; the language spec (see also SRFI 119)
(define-public guile2.2-wisp
(package
@@ -2204,7 +2206,7 @@ library.")
(inherit guile-ncurses)
(name "guile-ncurses-with-gpm")
(inputs `(("ncurses" ,ncurses/gpm)
- ("guile" ,guile-2.2)))))
+ ("guile" ,guile-3.0)))))
(define-public guile3.0-ncurses/gpm
(package
@@ -2742,6 +2744,7 @@ The picture values can directly be displayed in Geiser.")
("emacs-doom-modeline" ,emacs-doom-modeline)
("emacs-modus-themes" ,emacs-modus-themes)
("emacs-geiser" ,emacs-geiser)
+ ("emacs-geiser-guile" ,emacs-geiser-guile)
("emacs-company" ,emacs-company)
("emacs-ivy" ,emacs-ivy)
("emacs-flycheck" ,emacs-flycheck)
@@ -4663,3 +4666,27 @@ properties inspired by ghc-quickcheck. You can use it to express properties,
which functions should satisfy, as Scheme code and then check whether they hold
in a large number of randomly generated test cases.")
(license license:gpl3+)))
+
+(define-public guile-fslib
+ (package
+ (name "guile-fslib")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/ZelphirKaltstahl/guile-fslib/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "118d84p443w7hrslv8hjyhgws631ia08mggiyklkmk0b9plfdsvz"))))
+ (build-system guile-build-system)
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://notabug.org/ZelphirKaltstahl/guile-fslib")
+ (synopsis "Helper functions for working with locations in file systems")
+ (description
+ "This package contains helper functions for working with file system
+locations.")
+ (license license:agpl3+)))