summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm36
1 files changed, 22 insertions, 14 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c79a7cd408..5fc486d186 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -752,20 +752,28 @@ extensive documentation, including API reference and a tutorial.")
(arguments
`(#:tests? #f
#:phases (alist-cons-after
- 'install 'install-pth
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; pygtk's modules are stored in a subdirectory of python's
- ;; site-packages directory. Add a .pth file so that python
- ;; will add that subdirectory to its module search path.
- (let* ((out (assoc-ref outputs "out"))
- (site (string-append out "/lib/python"
- ,(version-major+minor
- (package-version python-2))
- "/site-packages")))
- (call-with-output-file (string-append site "/pygtk.pth")
- (lambda (port)
- (format port "gtk-2.0~%")))))
- %standard-phases)))
+ 'configure 'fix-codegen
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "pygtk-codegen-2.0"
+ (("^prefix=.*$")
+ (string-append
+ "prefix="
+ (assoc-ref inputs "python-pygobject") "\n"))))
+ (alist-cons-after
+ 'install 'install-pth
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; pygtk's modules are stored in a subdirectory of python's
+ ;; site-packages directory. Add a .pth file so that python
+ ;; will add that subdirectory to its module search path.
+ (let* ((out (assoc-ref outputs "out"))
+ (site (string-append out "/lib/python"
+ ,(version-major+minor
+ (package-version python-2))
+ "/site-packages")))
+ (call-with-output-file (string-append site "/pygtk.pth")
+ (lambda (port)
+ (format port "gtk-2.0~%")))))
+ %standard-phases))))
(home-page "http://www.pygtk.org/")
(synopsis "Python bindings for GTK+")
(description