summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm75
1 files changed, 49 insertions, 26 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 256f298346..10d9011401 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -398,7 +398,7 @@ arrays of data.")
(define-public gstreamer-docs
(package
(name "gstreamer-docs")
- (version "1.18.1")
+ (version "1.18.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -406,7 +406,7 @@ arrays of data.")
"/gstreamer-docs-" version ".tar.xz"))
(sha256
(base32
- "0npnsr1z4x951nw8bfcna1xlgi1p0b4qb291jj3pywlib2lscnnv"))))
+ "07hrgn11ll16yahyyh5684k8ms1j9npsyb8lj0skwbapin4czshm"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
@@ -461,7 +461,7 @@ the GStreamer multimedia framework.")
(define-public gstreamer
(package
(name "gstreamer")
- (version "1.18.1")
+ (version "1.18.2")
(source
(origin
(method url-fetch)
@@ -470,7 +470,7 @@ the GStreamer multimedia framework.")
version ".tar.xz"))
(sha256
(base32
- "1fpcpsw740svvdxvvwn0hly5i72miizm4s0mbid10ji83zi8vpvr"))))
+ "0ijlmvr660m8zn09xlmnq1ajrziqsivp2hig5a9mabhcjx7ypkb6"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -521,7 +521,7 @@ This package provides the core library and elements.")
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
- (version "1.18.1")
+ (version "1.18.2")
(source
(origin
(method url-fetch)
@@ -529,7 +529,7 @@ This package provides the core library and elements.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0hf66sh8d4x2ksfnvaq2rqrrfq0vi0pv6wbh9i5jixrhvvbm99hv"))))
+ "1b05kg46azrxxvq42c71071lfsnc34pw4vynnkczdqi6g0gzn16x"))))
(build-system meson-build-system)
(propagated-inputs
`(("glib" ,glib) ;required by gstreamer-sdp-1.0.pc
@@ -583,7 +583,7 @@ for the GStreamer multimedia library.")
(define-public gst-plugins-good
(package
(name "gst-plugins-good")
- (version "1.18.1")
+ (version "1.18.2")
(source
(origin
(method url-fetch)
@@ -592,21 +592,13 @@ for the GStreamer multimedia library.")
"https://gstreamer.freedesktop.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0v329xi4qhlfh9aksfyviryqk9lclm4wj1lxrjnbdv4haldfj472"))))
+ (base32 "1929nhjsvbl4bw37nfagnfsnxz737cm2x3ayz9ayrn9lwkfm45zp"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases
(modify-phases %standard-phases
,@%common-gstreamer-phases
- (add-after 'unpack 'fix-broken-test
- (lambda _
- ;; Fix test failure on 32-bit. Remove for > 1.18.1.
- ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues/803
- (substitute* "tests/check/elements/qtdemux.c"
- (("10000000")
- "G_GUINT64_CONSTANT (10000000)"))
- #t))
(add-before 'check 'pre-check
(lambda _
;; Tests require a running X server.
@@ -681,14 +673,14 @@ model to base your own plug-in on, here it is.")
(define-public gst-plugins-bad
(package
(name "gst-plugins-bad")
- (version "1.18.1")
+ (version "1.18.2")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/src/"
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "1cn18cbqyysrxnrk5bpxdzd5xcws9g2kmm5rbv00cx6rhn69g5f1"))))
+ "06ildd4rl6cynirv3p00d2ddf5is9svj4i7mkahldzhq24pq5mca"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -789,7 +781,7 @@ par compared to the rest.")
(define-public gst-plugins-ugly
(package
(name "gst-plugins-ugly")
- (version "1.18.1")
+ (version "1.18.2")
(source
(origin
(method url-fetch)
@@ -797,7 +789,7 @@ par compared to the rest.")
(string-append "https://gstreamer.freedesktop.org/src/"
name "/" name "-" version ".tar.xz"))
(sha256
- (base32 "09gpbykjchw3lb51ipxj53fy238gr9mg9jybcg5135pb56w6rk8q"))))
+ (base32 "1nwbcv5yaib3d8icvyja3zf6lyjf5zf1hndbijrhj8j7xlia0dx3"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
@@ -848,7 +840,7 @@ think twice about shipping them.")
(define-public gst-libav
(package
(name "gst-libav")
- (version "1.18.1")
+ (version "1.18.2")
(source
(origin
(method url-fetch)
@@ -857,7 +849,7 @@ think twice about shipping them.")
"https://gstreamer.freedesktop.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1n1fkkbxxsndblnbm0c2ziqp967hrz5gag6z36xbpvqk4sy1g9rr"))))
+ (base32 "0jbzams9ggk3sq9ywv4gsl9rghyn203l2582m6l5c1sz9ka9m5in"))))
(build-system meson-build-system)
(native-inputs
`(("perl" ,perl)
@@ -878,7 +870,7 @@ decoders, muxers, and demuxers provided by FFmpeg.")
(define-public gst-editing-services
(package
(name "gst-editing-services")
- (version "1.18.1")
+ (version "1.18.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -886,7 +878,7 @@ decoders, muxers, and demuxers provided by FFmpeg.")
"gst-editing-services-" version ".tar.xz"))
(sha256
(base32
- "09rr5a198p1r9wcbsjl01xg6idkfkgj5h9x7xxywarb5i7qv6g79"))))
+ "0pv2k8zlpn3vv2sdlspi3m63ixcwzi90pjly2ypbkg59ab97rb15"))))
(build-system meson-build-system)
(arguments
;; FIXME: 16/22 failing tests.
@@ -898,6 +890,8 @@ decoders, muxers, and demuxers provided by FFmpeg.")
("libxml2" ,libxml2)))
(native-inputs
`(("flex" ,flex)
+ ("gobject-introspection" ,gobject-introspection)
+ ("glib:bin" ,glib "bin")
("gst-plugins-bad" ,gst-plugins-bad)
("gst-plugins-good" ,gst-plugins-good)
("perl" ,perl)
@@ -910,10 +904,39 @@ decoders, muxers, and demuxers provided by FFmpeg.")
non-linear editors.")
(license license:gpl2+)))
+(define-public gst-plugins/selection
+ (lambda* (pkg #:key plugins configure-flags)
+ "Build PKG with only PLUGINS enabled. Optionally, if CONFIGURE-FLAGS are
+given, also pass them to the build system instead of the ones used by PKG."
+ (package/inherit pkg
+ (arguments
+ (substitute-keyword-arguments (package-arguments pkg)
+ ((#:configure-flags flags `(,@(or configure-flags '())))
+ `(append
+ (list
+ ,@(map (lambda (plugin)
+ (string-append "-D" plugin "=enabled"))
+ plugins))
+ (list ,@(or configure-flags flags))))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'disable-auto-plugins
+ (lambda _
+ (substitute* "meson_options.txt"
+ (("'auto'") "'disabled'"))
+ #t)))))))))
+
+(define-public gst-transcoder
+ (deprecated-package
+ "gst-transcoder"
+ (gst-plugins/selection gst-plugins-bad
+ #:plugins '("transcoder")
+ #:configure-flags '("-Dintrospection=enabled"))))
+
(define-public python-gst
(package
(name "python-gst")
- (version "1.18.1")
+ (version "1.18.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -921,7 +944,7 @@ non-linear editors.")
"gst-python-" version ".tar.xz"))
(sha256
(base32
- "1xpncj9xdn6ycnmrqnk6iaqaia658licyj08cxbjgcvs5x18kcj2"))))
+ "171qxzndii7ynn9ag3a12h9vyydxzwy1j4ip3cb8hgim1dv0z7g1"))))
(build-system meson-build-system)
(arguments
`(#:modules ((guix build meson-build-system)