summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index cf392f5468..dd679f1582 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -3,6 +3,8 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,14 +38,13 @@
(define-public groff
(package
(name "groff")
- (version "1.22.3")
+ (version "1.22.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/groff/groff-" version
".tar.gz"))
(sha256 (base32
- "1998v2kcs288d3y7kfxpvl369nqi06zbbvjzafyvyl3pr7bajj1s"))
- (patches (search-patches "groff-source-date-epoch.patch"))))
+ "14q2mldnr1vx0l9lqp9v2f6iww24gj28iyh4j2211hyynx67p3p7"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;12MiB of PS, PDF, HTML, and examples
@@ -65,7 +66,11 @@
(add-after 'unpack 'setenv
(lambda _
(setenv "GS_GENERATE_UUIDS" "0")
- #t)))))
+ #t))
+ (add-after 'unpack 'fix-docdir
+ (lambda _ ;see https://savannah.gnu.org/bugs/index.php?55461
+ (substitute* "Makefile.in"
+ (("^docdir =.*") "docdir = @docdir@\n")))))))
(synopsis "Typesetting from plain text mixed with formatting commands")
(description
"Groff is a typesetting package that reads plain text and produces
@@ -91,7 +96,7 @@ is usually the formatter of \"man\" documentation pages.")
(arguments
`(#:disallowed-references (,perl)
- #:configure-flags '("--docdir=/tmp/trash/doc")
+ #:configure-flags '("--with-doc=no")
,@(substitute-keyword-arguments (package-arguments groff)
((#:phases phases)