summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm39
1 files changed, 37 insertions, 2 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 2fefb41c0a..58c0fa82fe 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,6 +44,7 @@
#:use-module (gnu packages gd)
#:use-module (gnu packages swig)
#:use-module (gnu packages python)
+ #:use-module (gnu packages tex)
#:use-module ((guix licenses) #:prefix license:))
(define-public graphviz
@@ -115,13 +117,13 @@ interfaces for other technical domains.")
(define-public python-graphviz
(package
(name "python-graphviz")
- (version "0.8.1")
+ (version "0.8.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "graphviz" version ".zip"))
(sha256
(base32
- "00rzqsmq25b0say05vix5xivchdvsv83jl2i8pkryqd0nz4bxzvb"))))
+ "148h7ln8z65c1723w9vpx8khkvl9iigh8csv0qd4pidc53042rv0"))))
(build-system python-build-system)
(native-inputs
`(("unzip" ,unzip)))
@@ -239,3 +241,36 @@ graphs in Graphviz's DOT language, written in pure Python.")
(define-public python2-pydot
(package-with-python2 python-pydot))
+
+(define-public dot2tex
+ (package
+ (name "dot2tex")
+ (version "2.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "dot2tex" version))
+ (sha256
+ (base32
+ "0jhdwp0wv2h0xb7j2s5xiv7i8yaqgfpwwqcyrjvaxkfwsynm8gkx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (inputs
+ `(("texlive-latex-preview" ,texlive-latex-preview)
+ ("graphviz" ,graphviz)))
+ (propagated-inputs
+ `(("python-pyparsing" ,python2-pyparsing)))
+ (home-page "https://github.com/kjellmf/dot2tex")
+ (synopsis "Graphviz to LaTeX converter")
+ (description
+ "The purpose of @code{dot2tex} is to give graphs generated by Graphviz a
+more LaTeX friendly look and feel. This is accomplished by converting
+@code{xdot} output from Graphviz to a series of PSTricks or PGF/TikZ commands.
+This approach allows:
+
+@itemize @bullet
+@item Typesetting labels with LaTeX, allowing mathematical notation
+@item Using native PSTricks and PGF/TikZ commands for drawing arrows
+@item Using backend specific styles to customize the output
+@end itemize")
+ (license license:expat)))