summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm39
1 files changed, 36 insertions, 3 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9879130e20..411d89fcc2 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
+;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -428,17 +429,47 @@ with the @command{autotrace} utility or as a C library, @code{libautotrace}.")
(license (list license:gpl2+ ;for the utility itself
license:lgpl2.1+))))) ;for use as a library
+(define-public embree
+ (package
+ (name "embree")
+ (version "3.12.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/embree/embree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0aznd16n7h8g3f6jcahzfp1dq4r7wayqvn03wsaskiq2dvsi4srd"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests (apparently)
+ #:configure-flags
+ (list
+ "-DEMBREE_ISPC_SUPPORT=OFF")))
+ (inputs
+ `(("tbb" ,tbb)
+ ("glfw" ,glfw)))
+ (home-page "https://www.embree.org/")
+ (synopsis "High performance ray tracing kernels")
+ (description
+ "Embree is a collection of high-performance ray tracing kernels.
+Embree is meant to increase performance of photo-realistic rendering
+applications.")
+ (license license:asl2.0)))
+
(define-public blender
(package
(name "blender")
- (version "2.83.9")
+ (version "2.91.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.blender.org/source/"
"blender-" version ".tar.xz"))
(sha256
(base32
- "106w9vi6z0gi2nbr73g8pm40w3wn7dkjcibzvvzbc786yrnzvkhb"))))
+ "0x396lgmk0dq9115yrc36s8zwxzmjr490sr5n2y6w27y17yllyjm"))))
(build-system cmake-build-system)
(arguments
(let ((python-version (version-major+minor (package-version python))))
@@ -510,7 +541,8 @@ with the @command{autotrace} utility or as a C library, @code{libautotrace}.")
("python" ,python)
("python-numpy" ,python-numpy)
("tbb" ,tbb)
- ("zlib" ,zlib)))
+ ("zlib" ,zlib)
+ ("embree" ,embree)))
(home-page "https://blender.org/")
(synopsis "3D graphics creation suite")
(description
@@ -588,6 +620,7 @@ application can be customized via its API for Python scripting.")
`(("boost" ,boost)
("jemalloc" ,jemalloc)
("libx11" ,libx11)
+ ("opencolorio" ,opencolorio)
("openimageio" ,openimageio)
("openexr" ,openexr)
("ilmbase" ,ilmbase)