summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index e0f489f8de..4fa3bcef19 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -6,6 +6,8 @@
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -51,24 +53,25 @@
(define-public gpsbabel
(package
(name "gpsbabel")
- (version "1.5.4")
+ (version "1.7.0")
(source (origin
- (method url-fetch)
- ;; XXX: Downloads from gpsbabel.org are hidden behind a POST, so
- ;; get it from elsewhere.
- (uri (string-append
- "mirror://debian/pool/main/g/gpsbabel/gpsbabel_"
- version ".orig.tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gpsbabel/gpsbabel")
+ (commit (string-append
+ "gpsbabel_"
+ (string-replace-substring version "." "_")))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "19hykxhyl567gf8qcrl33qhv95w0g4vxw9r3h9b8d8plx9bnaf8l"))
- (patches (search-patches
- "gpsbabel-minizip.patch"
- ;; XXX: Remove this patch on the next release.
- "gpsbabel-qstring.patch"))
+ "010g0vd2f5knpq5p7qfnl31kv3r8m5sjdsafcinbj5gh02j2nzpy"))
+ (patches (search-patches "gpsbabel-fix-i686-test.patch"))
(modules '((guix build utils)))
(snippet
'(begin
+ (delete-file-recursively "zlib")
+ (substitute* "Makefile.in"
+ ((" zlib/z.*\\.h") ""))
;; Delete files under GPL-compatible licences but never used
;; on GNU systems, rather than bloating the LICENSE field.
(delete-file "gui/serial_mac.cc") ; Apple MIT
@@ -78,17 +81,12 @@
;; TODO: "make doc" requires Docbook & co.
(arguments
`(#:configure-flags
- '("--with-zlib=system")
- ;; On i686, 'raymarine.test' fails because of a rounding error:
- ;; <http://hydra.gnu.org/build/133040>. As a workaround, disable tests
- ;; on these platforms.
- ;; FIXME: On x86_64 with -std=gnu++11 tests also fail due to rounding
- ;; error.
- #:tests? #f))
+ '("--with-zlib=system")))
(inputs
`(("expat" ,expat)
- ("zlib" ,zlib)
- ("qtbase" ,qtbase)))
+ ("libusb" ,libusb)
+ ("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
(native-inputs
`(("which" ,which)
("qttools" ,qttools)