summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index cd2e09e966..4a4b18f3e1 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -86,10 +87,10 @@
(inputs
`(("expat" ,expat)
("zlib" ,zlib)
- ("qtbase" ,qtbase)
- ("qttools" ,qttools)))
+ ("qtbase" ,qtbase)))
(native-inputs
`(("which" ,which)
+ ("qttools" ,qttools)
("libxml2" ,libxml2))) ;'xmllint' needed for the KML tests
(home-page "https://www.gpsbabel.org/")
(synopsis "Convert and exchange data with GPS and map programs")
@@ -220,14 +221,14 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
(define-public gpsd
(package
(name "gpsd")
- (version "3.19")
+ (version "3.20")
(source
(origin
(method url-fetch)
(uri (string-append "https://download-mirror.savannah.gnu.org"
"/releases/gpsd/gpsd-" version ".tar.gz"))
(sha256
- (base32 "0faz2mvk82hi7ispxxih07lhpyz5dazs4gcknym9piiabga29p97"))))
+ (base32 "0l2yz0yw9sil82lh2l4swkkldgmhzhv588n5lcavib4f0q2phahp"))))
(build-system scons-build-system)
(native-inputs
`(("bc" ,bc)
@@ -235,6 +236,7 @@ such as elevation, speed, heart rate, power, temperature, and gear shifts.")
(inputs
`(("bluez" ,bluez)
("dbus" ,dbus)
+ ("gtk+" ,gtk+)
("libcap" ,libcap)
("libusb" ,libusb)
("ncurses" ,ncurses)