summaryrefslogtreecommitdiff
path: root/gnu/packages/gpodder.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gpodder.scm')
-rw-r--r--gnu/packages/gpodder.scm28
1 files changed, 21 insertions, 7 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 8bf69c6551..6963da9dff 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019, 2020 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,7 +38,7 @@
(define-public gpodder
(package
(name "gpodder")
- (version "3.10.13")
+ (version "3.10.15")
(source
(origin
(method git-fetch)
@@ -46,11 +47,13 @@
(commit version)))
(sha256
(base32
- "1h542syaxsx1hslfzlk3fx1nbp190zjw35kigw7a1kx1jwvfwapg"))
+ "0ghbanj142n0hgydzfjmnkdgri2kswsjal3mn10c723kih4ir4yr"))
(file-name (git-file-name name version))))
(build-system python-build-system)
(native-inputs
- `(("intltool" ,intltool)))
+ `(("intltool" ,intltool)
+ ("python-coverage" ,python-coverage)
+ ("python-minimock" ,python-minimock)))
(inputs
`(("gtk+" ,gtk+)
("python-pygobject" ,python-pygobject)
@@ -71,6 +74,12 @@
(substitute* "src/gpodder/util.py"
(("xdg-open") (string-append xdg-utils "/bin/xdg-open")))
#t)))
+ (replace 'check
+ (lambda _
+ ; The `unittest' target overrides the PYTHONPATH variable.
+ (substitute* "makefile"
+ (("PYTHONPATH=src/") "PYTHONPATH=${PYTHONPATH}:src/"))
+ (invoke "make" "unittest")))
;; 'msgmerge' introduces non-determinism by resetting the
;; POT-Creation-Date in .po files.
(add-before 'install 'do-not-run-msgmerge
@@ -167,16 +176,21 @@ downloading episode status changes.")
(define-public python-podcastparser
(package
(name "python-podcastparser")
- (version "0.6.4")
+ (version "0.6.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "podcastparser" version))
(sha256
- (base32
- "1ksj1gcmbnm5i43xhpqxbs2mqi6xzawwwkwbh9h6lwa1wxxvv247"))))
+ (base32 "0k62ppg20i41gcc5x8ddjn7zbpy47hqpxzrq9257g2c71m4qw07b"))))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-coverage" ,python-coverage)
+ ("python-nose" ,python-nose)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "nosetests"))))))
(build-system python-build-system)
(home-page "http://gpodder.org/podcastparser")
(synopsis "Simplified and fast RSS parser Python library")