summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index adb6bbe488..f270c780ab 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2861,10 +2861,21 @@ Go.")
(file-name (git-file-name name version))
(sha256
(base32
- "0pcdvakxgddaiwcdj73ra4da05a3q4cgwbpm2w75ycq4kzv8ij8k"))))
+ "0pcdvakxgddaiwcdj73ra4da05a3q4cgwbpm2w75ycq4kzv8ij8k"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "vendor")))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/stretchr/objx"))
+ (propagated-inputs
+ (list go-github-com-davecgh-go-spew
+ go-github-com-pmezard-go-difflib))
+ (inputs
+ (list go-github-com-stretchr-testify-bootstrap))
+ (native-inputs
+ (list go-gopkg-in-yaml-v2))
(home-page "https://github.com/stretchr/objx")
(synopsis "Go package for dealing with maps, slices, JSON and other data")
(description "This package provides a Go library for dealing with maps,
@@ -2907,6 +2918,16 @@ Features include:
@end itemize")
(license license:expat)))
+(define go-github-com-stretchr-testify-bootstrap
+ (package
+ (inherit go-github-com-stretchr-testify)
+ (arguments
+ '(#:import-path "github.com/stretchr/testify"
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ (delete 'build))))
+ (propagated-inputs '())))
+
(define-public go-github-com-tevino-abool
(let ((commit
"3c25f2fe7cd0ef3eabefce1d90efd69a65d35b12")