summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2ef17616e9..d92f4242c9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8884,6 +8884,32 @@ well-suited for simple and complex terminal applications, either inline,
full-window, or a mix of both.")
(license license:asl2.0)))
+(define-public go-github-com-containerd-console
+ (package
+ (name "go-github-com-containerd-console")
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containerd/console")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pgx0y8x23jwc2f9jfk5hd5aslqk599nj6c7dj5846xvnkz2x7p2"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/containerd/console"))
+ (propagated-inputs
+ `(("golang.org/x/sys" ,go-golang-org-x-sys)))
+ (home-page "https://github.com/containerd/console")
+ (synopsis "Console package for Go")
+ (description
+ "This is Golang package for dealing with consoles. It has few
+dependencies and a simple API.")
+ (license license:asl2.0)))
+
(define-public go-github-com-arceliar-ironwood
(package
(name "go-github-com-arceliar-ironwood")